Re: Failing to configure cdr replicas between 10.00FC9W2 and 11.50FC6
Posted in 2010
On May 5, 10:06 am, TripleDES <triple...@gmail.com> wrote:
> On May 4, 8:47 pm, jrenaut <jpren...@yahoo.com> wrote:
>
>
>
> > On May 4, 11:38 am, TripleDES <triple...@gmail.com> wrote:
>
> > > Hi,
>
> > > first of all, have to say I'm pretty new to Informix...was coming from
> > > Oracle world, at my new position we only have Informix so I'm having a
> > > little bit of funny time getting use to it. But overall, I'm pretty
> > > amazed with Informix.
>
> > > Now, to my problem. We're in the process to migrate our current 10.00
> > > installation with some replicas to 11.50. As first step we're trying
> > > to upgrade the non-root nodes to 11.50 but we're facing some problems.
> > > Let's name the nodes to try to keep things clear enough, please excuse
> > > my terminology I'm sure I'm telling names that you might find wrong or
> > > having nothing to do with Informix.
>
> > > - Main node (leaf node??) -> suxdb and g_dbmain
> > > - non root node -> sux11 (g_sux11)
>
> > > I have set up a server cloned from a production one to do the tests
> > > (sux11), have dropped syscdr database and defined it on the main
> > > server (suxdb) as a new node, included it on the replicasets and
> > > everything worked as expected on 10.00FC9W2. Once everything was set
> > > up, took down the instance, upgraded to 11.50FC6 and now I can't get
> > > cdr to re-connect the server, the migration process didn't report any
> > > error.
>
> > > Once the instance was in quiescent mode, I shut it down and got it up
> > > with 'oninit -D', once started properly I tried issuing a 'cdr start'
> > > on the sux11 and it produced the following messages on the main
> > > server's online.log:
>
> > > 18:12:47 CDR: Re-connected to server, id 2000, name <g_sux11>
> > > 18:12:48 CDR connection to server lost, id 2000, name <g_sux11>> > > Reason: disconnect server
>
> > > Trying to connect from main server to the node using 'cdr connect
> > > server -c g_sux11 g_sux11' gives me a message...my boss wouldn't like
> > > to see... ;)
>
> > > connect to g_sux11 failed
> > > This feature of Enterprise Replication is not yet supported. (101)
> > > command failed -- unable to connect to server specified (5)
>
> > > This is the same message I got when tried to delete the server
> > > definition and re-define it as non-root node. Getting these messages,
> > > I got the feeling that what I'm trying to achieve is not really
> > > supported....hope to be wrong.
>
> > > Thanks in advance, I'm also trying to get in touch with IBM support to
> > > see if they could throw some light on this set up....
>
> > > Sergio.
>
> > If I understand what you are saying, I think you've possibly missed
> > some steps. So you set up a new server and got ER working with it
> > under version 10.x...you then brought it off-line, got all instance
> > set up pointing at a new 11.50 install place and then brought it up
> > with oninit -D. I believe at this point you need to do a conversion
> > on your syscdr database. Check outhttp://publib.boulder.ibm.com/infocenter/idshelp/v115/index.jsp?topic...
> > for more info. Sorry if you have already done this after before/after
> > bringing the instance up with the new 11.50 product.
>
> > Jacques Renaut
> > IBM Informix Advanced Support
> > APD Team
>
> Thank you so much Jacques!
> That seemed to do the trick!
>
> I've been trying to open a ticket request on IBM support but was
> having trouble to access to the site, my firefox says something about
> an infinite redirection and doesn't load the site....but we're good to
> go now! we'll do further testing.
>
> Again, thank you.
>
> Sergio.
Hi....again...
Silly me...I have spoken too soon, everything seems to be working but
the synchronization...
I got to understand that I need to issue commands like 'cdr check repl
-c g_dbmain....blabla' from the upgraded node (sux11) cause the 10.00
doesn't like to connect to an 11.50 instance...so executing the
following check from sux11 it returns that there hasn't been any data
processed:
informix@suxids11:~/etc/conv> cdr check repl -c g_dbmain -m g_dbmain -
r ctercero g_sux11
May 06 2010 09:31:34 ------ Table scan for ctercero start --------
Node Rows Extra Missing Mismatch Processed
---------------- --------- --------- --------- --------- ---------
g_dbmain 15850 0 0 0 0
g_sux11 15831 0 19 842 0
WARNING: replicate is not in sync
May 06 2010 09:31:46 ------ Table scan for ctercero end ---------
command failed -- WARNING: replicate is not in sync (178)
So...I thought, let's sync from sux11!....and there comes the problem:
informix@suxids11:~/etc/conv> cdr sync repl -c g_dbmain -m g_dbmain -r
ctercero g_sux11
SYNC:Replicate ctercero is not active
ctercero at node g_dbmainThe specified replicate is not in an active
state on the master node.
Perform the following actions and then run the above repair command
again:
1. Use the \\"cdr list repl\\" command to check the current
state
of the replicate.
2. Make the replicate active:
- If the replicate is stopped, then use the \\"cdr
start repl\\"
command to start it.
- If the replicate is suspended, then use the \\"cdr
resume repl\\"
command to resume it.
May 06 2010 09:33:12 ------ Table scan for ctercero end ---------
command failed -- Sync attemped on replicate which is not active (176)
I thought it might got stopped while working with the new instance:
informix@suxids11:~/etc/conv> cdr list repl -c g_dbmain ctercero
DEFINED REPLICATES ATTRIBUTES
------------------------------
REPLICATE: ctercero
STATE: Active ON:g_dbmain
CONFLICT: Ignore
FREQUENCY: every 03:00
QUEUE SIZE: 0
PARTICIPANT: fedefarm:informix.ctercero
OPTIONS: row,ats,fullrow
REPLID: 65558 / 0x10016
REPLMODE: PRIMARY ON:g_dbmain
APPLY-AS: INFORMIX ON:g_dbmain
REPLTYPE: Master
The two instances have been connected for about 12h and any row has
been processed, so I guess I might be missing something else...I'm
reviewing the documentation Jacques pointed yesterday but I can't find
nothing else...
Any help would be much appreciated.
Sergio.