WARNING: mt_aio_wait: errno == EINVAL
Posted in 2008
Topics: Connectivity: ODBC / JDBC / .NET, Security, Permissions & Auditing, Logging & Checkpoints, Platform-Specific Issues
Greetings,
IDS: 10.00.FC7
OS: AIX 64bit 5300-05-CSP
One of our instances went silly and refused each and every user connection.
Here's a short excerpt from the online log:
IBM Informix Dynamic Server Version 10.00.FC7 -- On-Line -- Up 72 days
20:06:11 -- 121424 Kbytes
...18:30:39 Fuzzy Checkpoint Completed: duration was 0 seconds, 127 buffers not
flushed.
18:30:39 Checkpoint loguniq 5975, logpos 0x483c28, timestamp: 0xfbb535c
18:30:39 Maximum server connections 119
18:34:39 WARNING: mt_aio_wait: errno == EINVAL
18:34:39 listener-thread: err = -951: oserr = 0: errstr = smartsrv@utils3:
Incorrect password or user smartsrv@utils3 is not known on the database server.
...
All new local and remote connections for ALL users including informix failed
producing the -951 error in the log and "WARNING: mt_aio_wait: errno ==
EINVAL" every now and then.
The only option was to bounce the instance and things were back to normal.
This sort of downtime is unacceptable in production environment.
Has anyone experienced this error and know how to get rid of it?
On a different note, I am slightly interested in upgrading to IDS11, but is it
production stable? What problems am I most likely to encounter with our
inhouse applications connecting via ODBC and perl DBI via DBD::Informix?
Server hardware platform will remain the same, 64bit AIX on Power5+ (P550). We
don't want yet another can of worms and problems.
thanks,
--IAM
After some research and talking to Informix Tech Support... I decided to create a new instance and then start connecting/disconnecting in a fairly busy loop... when the total connect/disconnect counter hit a little over 4 million, the same error happened. I can now reproduce the error. I sent log files to IFX Tech Support and they should get back with me next week. I am guessing this is possibly an AIX issue... I don't know yet. Anyone want to comment on the IDS11 I asked? --IAM
After researching the error I've come to following conclusions, based on my company's hardware/software configuration: AIX 5.3 below ML5, you may see this error after ~1 million connects/disconnects. AIX 5.3 at ML5, you may see this error after ~4 million connects/disconnects. AIX 5.3 at ML6, not tested. AIX 5.3 at ML7, tested to ~45 million connects/disconnects and it didn't break. I consider this problem solved for the time being, my next course of action is to deploy ML7 in development and start testing the system and later down the road perform the same ML7 deployment in production. Hopefully this helps some DBA/sysadmin searching for answers.