Problem with check point
Posted in 2011
Topics: High Availability & Replication, Storage & Space Management, Logging & Checkpoints, Jobs, Consulting & Announcements
Hello All, My database is running on IDS 11.50.FC8W3 with HDR and RSS , I have a problem when I have tried to add space chunk of 8 GB in dbspace during the chunk addition database respond very slowly and ultimately checkpoint blocked up 70 seconds and following errors found in message log file 14:36:16 RSS ids_net_rss90 ACK timeout 14:36:17 RSS ids_net_rss90 is not acknowledging log transmission 14:36:22 DR: Primary server connected 14:36:22 DR_ERR set to -2 14:36:22 DR: Failure recovery error (2) 14:36:23 DR: Turned off on primary server 14:36:23 DR: Cannot connect to secondary server 14:36:34 DR: Primary server connected 14:36:34 DR_ERR set to -2 14:36:34 DR: Failure recovery error (2) 14:36:35 DR: Turned off on primary server 14:36:35 DR: Cannot connect to secondary server 14:36:46 DR: Primary server connected 14:36:46 DR_ERR set to -2 14:36:46 DR: Failure recovery error (2) 14:36:47 DR: Turned off on primary server 14:36:47 DR: Cannot connect to secondary server 14:36:58 DR: Primary server connected 14:36:58 DR_ERR set to -2 14:36:58 DR: Failure recovery error (2) 14:36:59 DR: Turned off on primary server 14:36:59 DR: Cannot connect to secondary server 14:37:09 DR: Primary server connected 14:37:09 DR_ERR set to -2 14:37:09 DR: Failure recovery error (2) 14:37:11 DR: Turned off on primary server 14:37:11 DR: Cannot connect to secondary server 14:37:12 SMX thread is exiting because it received a CLOSE message from a remote server 14:37:22 DR: Primary server connected 14:37:22 DR: Secondary server needs failure recovery 14:37:24 Logical Log 4531 Complete, timestamp: 0x52e79e13. 14:37:25 DR: Sending log 4531, size 50000 pages, 45.74 percent used 14:37:39 DR: Sending log 4532 (current), size 50000 pages, 6.58 percent used 14:37:42 DR: Sending Logical Logs Completed 14:37:43 DR: Primary server operational 14:38:04 Checkpoint Completed: duration was 70 seconds. 14:38:04 Maximum server connections 12 14:38:04 Checkpoint Statistics - Avg. Txn Block Time 0.615, # Txns blocked 60, Plog used 1375, Llog used 16907 14:40:20 RSS ids_net_rss90 has resumed acknowledgement 14:40:20 RSS ids_net_rss90 resumed acknowledging log transmission 2011-06-08 14:48:13 Servername:ids_accounts90 <<IBM Informix Dynamic Server>>> Logical Log 4532 Complete, timestamp: 0x52fdcbb4. 14:48:13 Logical Log 4532 Complete, timestamp: 0x52fdcbb4. 2011-06-08 15:14:15 Servername:ids_accounts90 <<IBM Informix Dynamic Server>>> Logical Log 4533 Complete, timestamp: 0x531252f8. 15:14:15 Logical Log 4533 Complete, timestamp: 0x531252f8. 15:21:26 Chunk '/export/ids_space/datadbs_accounts90_5' added to space 'datadbs_accounts90'.
Original post:
Hello All,
My database is running on IDS 11.50.FC8W3 with HDR and RSS , I have a problem
when I have tried to add space chunk of 8 GB in dbspace during the chunk
addition database respond very slowly and ultimately checkpoint blocked up 70
seconds and following errors found in message log file
14:36:16 RSS ids_net_rss90 ACK timeout
14:36:17 RSS ids_net_rss90 is not acknowledging log transmission
14:36:22 DR: Primary server connected
14:36:22 DR_ERR set to -2
<stuff cut out>
14:37:43 DR: Primary server operational
14:38:04 Checkpoint Completed: duration was 70 seconds.
14:38:04 Maximum server connections 12
14:38:04 Checkpoint Statistics - Avg. Txn Block Time 0.615, # Txns blocked 60,
Plog used 1375, Llog used 16907
14:40:20 RSS ids_net_rss90 has resumed acknowledgement
14:40:20 RSS ids_net_rss90 resumed acknowledging log transmission
2011-06-08 14:48:13 Servername:ids_accounts90
<<IBM Informix Dynamic Server>>> Logical Log 4532 Complete, timestamp:
0x52fdcbb4.
14:48:13 Logical Log 4532 Complete, timestamp: 0x52fdcbb4.
2011-06-08 15:14:15 Servername:ids_accounts90
<<IBM Informix Dynamic Server>>> Logical Log 4533 Complete, timestamp:
0x531252f8.
15:14:15 Logical Log 4533 Complete, timestamp: 0x531252f8.
15:21:26 Chunk '/export/ids_space/datadbs_accounts90_5' added to space
'datadbs_accounts90'.
Response:
So you are saying that you kicked off the onspaces command to add the chunk at
or around 14:36 and then it didn't add on the primary until 15:21 (almost an
hour later)? I can't really think of why adding a chunk on the primary would
cause both your RSS secondary and HDR secondary to disconnect, but then
immediately reconnect but then still take another 40 minutes to add the chunk.
Are you sure the disconnects were caused by adding the chunk? Or might there
have been something else going on at 14:36 but the only thing in the MSGPATH
file is the chunk getting added a bit after the problem?
Jacques Renaut
IBM Informix Advanced Support
APD Team
There is nothing else was running on the database only space chunk was adding . I have repeat the scenario many times when I was trying to add space chunk more than 2 GB problem started .