Re: 4gl CURSOR Error 469
Posted in 2001
Topics: Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL
In article <3a6f5ba7$1@news.iprimus.com.au>, "Andrew Hamm" <ahamm@sanderson.net.au> wrote: > POSSIBLY there is something wrong with the select itself, and so it fails to > prepare. I woulda thought the 4GL should issue an error on that one I think it is ok; it works with isql and sqlca.sqlcode is 0. > but, is the function working under a WHENEVER {ANY} ERROR CONTINUE or > something equally liberal? Perhaps you might get more information if No, i can not get any data from the cursor. > slip in a WHENEVER ANY ERROR STOP and don't forget to call > startlog("errlog") so that you can see any error messages the 4GL > spits out - in the errlog file. In the errlogfile is only error 469. > > And to ask the really obvious dumb question, do the blk nxt and term > fields exist in the k_foot table on the platform where it's failing? The sql is ok! I attempt the same with FOREACH cursor_name instead of OPEN cursor_name with the same effect. Thank you! Thomas Sent via Deja.com http://www.deja.com/
Thomas Behr wrote in message <94opjr$ue1$1@nnrp1.deja.com>... > >In the errlogfile is only error 469. 469? I think Jonathan Leffler made a reply regarding that error recently. It might have even been in response to you? I can't find it because my news client draws air, liquid and objects into itself through pursed lips... Anyway, the gist of the reply was: check your $INFORMIXDIR/msg directory. various files used to be directy in that directory, but recent versions have shifted the files into subdirectories. On my distribution, they are now under msg/en_us/0333. In order to keep a few older executables running, we had to put some files BACK into the plain msg directory. I have this theory, that's totally unproven, that the various language tools use some of the messages to build templates that are submitted to the engines. This is suggested from odd errors we've seen when that directory has been scrambled. It also occurred when the products are installed incorrectly. We got sporadic error messages mentioning netsrv.iem that took a bit of figuring out before we realised the installation order of CDSK (I think) was responsible.
Andrew Hamm wrote in message <3a7a2964$1@news.iprimus.com.au>... >Thomas Behr wrote in message <94opjr$ue1$1@nnrp1.deja.com>... >> >>In the errlogfile is only error 469. > >469? I think Jonathan Leffler made a reply regarding that error recently. No, put-a-concrete-wall-across-it. I found the reply and it was about error 461. Anyways, can't hurt to check msg directory! Sorry I can't be of any better help to you. I can guess how frustrating it must be.