Re: Problem in installation on SCO 5.0.2
Posted in 1998
In article <01bd2d91$bc6fe700$5c2233c2@mussard.esker.fr>, ALLAN
<mussard@esker.fr> writes
>Hello,
>
>I'm trying to install a Informix online 7.22 on a unix SCO 5.0.2
>
>The installation runs well, and says :
>Install complete.
>when i'm starting oninit, i get the message :
>oninit:Fatal error initializing ASF with "ADF_INIT_DATA" flags;='-25580
>The finderr 25580 says A network error occured.
>BUT the tcp IP is running fine on the machine.
>
>In another hand, i get in the online.log the message ( last line ) :
>Failure, system out of semaphores.
This is your problem.
I had this yesterday on SCO Openserver 5.04
Check your release notes somewhere under $INFORMIXDIR/release in a
file called ONLINE_7.2
Set the kernle parameters there.
Use scoadmin and chosse Hardware/Kernel Manager, Tune Parameters
and set the ones under Semaphores and Shared Memory. Some
of them won't be listed there... bug in SCO...so add
them to /etc/conf/cf.d/stune. You will also need to change the
thrid value in the mtune file in that directory.
mtune - default values for kernel parameters and has the format
<name> <default value> <min value> <max value>
if you exceed the max value you will need to increase it in the
mtune file.
then relink the kernel saying yes to all the options and reboot..
>BUT i'am already with a SHMMAX of 6400 (max on SCO 100 !)
>and a SHMNI of 256 (Max could up to 300, but SHMMAX is 25xSHMNI), so...
>
>can anyone help me ?
>
>Thanx for all,
>
>Alain.
>
>
--
David Williams
Maintainer of the Informix FAQ
Primary site (Beta Version) http://www.smooth1.demon.co.uk
Official site http://www.iiug.org/techinfo/faq/faq_top.html
I see you standin', Standin' on your own, It's such a lonely place for you, For
you to be If you need a shoulder, Or if you need a friend, I'll be here
standing, Until the bitter end...
So don't chastise me Or think I, I mean you harm...
All I ever wanted Was for you To know that I care