unexpected error message
Posted in 1999
Hi,
this weekend, I was tunning my database, and I changed the LRUs and
CLEANERS parameter from 32 to 128. on startup, the engine showed the
following message:
Sun Mar 28 10:10:36 1999
10:10:36 Event alarms enabled. ALARMPROG =
'/baan/informix/etc/log_full.sh'
10:10:42 DR: DRAUTO is 0 (Off)
10:10:43 WARNING! Physical Log size 0 is too small. Physical Log overflows may occur during peak activity.
Recommended minimum Physical Log size is 20 times maximum
concurrent user threads.
10:10:43 WARNING! Logical log layout may cause OnLine to get into a locked state. Recommended smallest logical log size
is 2 times maximum concurrent user threads.
10:10:43 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
10:10:43 Physical Recovery Started.
10:10:43 Physical Recovery Complete: 0 Pages Restored.
10:10:43 Logical Recovery Started.
10:10:45 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
10:10:46 Onconfig parameter CLEANERS modified from 32 to 128.
10:10:46 Onconfig parameter LRUS modified from 32 to 128.
10:10:46 Dataskip is now OFF for all dbspaces
10:10:46 On-Line Mode
10:10:46 Checkpoint Completed: duration was 0 seconds.
10:12:14 INFORMIX-OnLine Stopped.
Of course, I shut down the engine and used 100 as working value (it
worked fine).
My question is: The error message that I expected was about something
else but physical log size. Why the engine reported a physical log error
if I had not changed that?
--
Arturo Rodr'guez Mutis
Director de Inform'tica
Melexa Ltda.
PBX (571) 360 3055
FAX (571) 360 2562
e-mail melexa@colomsat.net.co