Re: Dbspace question
Posted in 2012
Topics: Storage & Space Management, Migration, Import/Export & Data Conversion
Resurrecting the thread to learn if Larry was successful in taking Kern's
approach. Were you able to get the db loaded using "-d dbs1" and the tables
writing to dbs2?
We have a similar issue with detached indexes stored in their own dbspace, but
onload writes the indexes back into the main dbspace.
Thanks,
Michael
We haven't heard back from Larry, probably he was shot dead by his boss the
next day :) j/k
My apology to Larry regarding my false suggestion since I didn't read his
initial email thoroughly enough. My guess is, it would NEVER work for him
unless he tried something else.
This is what I've found over the years in dealing with onunload/onload; and
I'd like to share with you guys.
1. If you have table1 in dbs1, table2 in dbs2, etc. and table1's index in
idx1dbs, and so forth -- onload will reload everything into one dbspace. (we
all know that)
2. However, if your table1 is partitioned or fragmented into dbs1, dbs2, dbs3;
onload will automagically reload table1 in dbs1, dbs2, and dbs3 just like the
original -- you just make sure your target instance has those dbspaces or else
your load will fail. (this was what I thought Larry ran into)
3. If tables in your database reside in different dbspaces with different page
sizes, onunload "appears" to work, but it will fail when you do the onload.
(This is Larry's 2nd point of failure) Did IBM fix this bug? dunno.
4. onload appears to fix the extent of a highly extent fragmented table. For
example, if your table1 has 160 extents, you will do onunload of table1, drop
it, onload it, then check to see if it still has 160? probably not. (perhaps
Larry can do this quick-and-dirty trick to reorg his large table?)
And Michael,
I've developed scripts, onld and onuld to handle data and index separation
when reload. Tell me what you like to do so I can determine whether my scripts
could help.
Larry's notes....
>> The reason that we had to move some of the tables to a different
>> dbspace is that some of the tables were so large, they were running
>> out of extents and we had to create a dbspace with a larger page size.
>>
>> So, my question is, what is an equivalent command to copy this
>> database now that it occupies two dbspaces on the target?
________________________________
From: MICHAEL HOFFMAN <mrh@panix.com>
To: ids@iiug.org
Sent: Thursday, August 23, 2012 5:51 PM
Subject: Re: Dbspace question [28157]
Resurrecting the thread to learn if Larry was successful in taking Kern's
approach. Were you able to get the db loaded using "-d dbs1" and the tables
writing to dbs2?
We have a similar issue with detached indexes stored in their own dbspace, but
onload writes the indexes back into the main dbspace.
Thanks,
Michael
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.