IDS Installation error - Urgent
Posted in 2005
Topics: Installation, Setup & Upgrades, Platform-Specific Issues
Dear All We are installing "Informix Dynamic Server Version 7.31.FD3 " on AIX 5.2.=20 During installation we have faced the following error; # sh installserver ... ... .. Installing directory . Installing directory aaodir Installing directory bin exec(): 0509-036 Cannot load program etc/brand because of the following = errors: 0509-124 The program is a discontinued 64-bit object file. Installation of Informix Dynamic Server failed. We would appriciate if someone can provide us solution. Thanks in advance. Regards Paracha
On Friday 25 February 2005 13:14, you wrote: > Dear All > > We are installing "Informix Dynamic Server Version 7.31.FD3 > " on AIX 5.2.=20 > > During installation we have faced the following error; > > # sh installserver > .. > .. > . > Installing directory . > Installing directory aaodir > Installing directory bin > exec(): 0509-036 Cannot load program etc/brand because of the following = > errors: > 0509-124 The program is a discontinued 64-bit object file. > Installation of Informix Dynamic Server failed. Verify that you are installing the 64 bit versions of tools and server specifically labelled for AIX 5.2. The 64 bit version for AIX 4.3.3 will not work. DT -- Dave Thacker Senior Systems Administrator Omni Hotels Reservation Center V:402-952-6535 F:402-334-8013 M: 402-981-4613 (24/7)
Hi, this version of IDS has been built on AIX 4.3.2 and can be used on AIX 4.3.2 and AIX 4.3.3. Binary formats for 64-bit applications have changed between AIX 4.3.x and AIX 5.1.x. That's why you get this error. As far as I know there is no workaround to this problem. Either you upgrade to a newer version of IDS (9.40.x at the lowest, because all IDS 7.31.x are for AIX 4.3.x only), or you downgrade your OS. Regards, Martin -- Martin Fuerderer IBM Informix Development Munich, Germany Information Management forum.subscriber@iiug.org wrote on 25.02.2005 20:14:35: > Dear All > > We are installing "Informix Dynamic Server Version 7.31.FD3 > " on AIX 5.2.=20 > > During installation we have faced the following error; > > # sh installserver > .. > .. > . > Installing directory . > Installing directory aaodir > Installing directory bin > exec(): 0509-036 Cannot load program etc/brand because of the following = > errors: > 0509-124 The program is a discontinued 64-bit object file. > Installation of Informix Dynamic Server failed. > > > We would appriciate if someone can provide us solution. > > Thanks in advance. > > Regards > Paracha