HELP!--Windows NT processes at 100%
Posted in 1999
Topics: Security, Permissions & Auditing
Currently, whenever I start the IECC Server Agent service within the WinNT Services window, the CPU Usage in the Task Manager rockets up to 100%. When I looked to see who the culprit was, I discovered the "admagent.exe" process would continue to compensate for whatever CPU Usage balance was left. In other words, if all other processes accounted for 25% of the CPU, admagent.exe would adjust to 75%. If the overall processes decreased to 10%, then admagent.exe would rise to 90%. And so on, and so on....well, you get the picture. Unfortunately, this results in a bigger problem than simply a VERY slow server. When I open the IECC Console, Informix fails to detect the database server value (no blue dot). The result: Informix audit backups fail. Any suggestions or comments will be appreciated! Bryan Hughes Email: bhughes@med.osd.mil P.S.--If possible, please email with a response. My ability to connect to the Internet during the day is limited. Thanks...again!
Bryan,
Don't use IECC, it's a resource hog.
Use the command line programs and dbaccess.
Too bad they removed onmonitor on NT only to be replaced
by a useless substitute.
------------------
Lyzander
Informix DBA
Bell Atlantic
In article <7dp8mi$3b8$1@camel21.mindspring.com>,
"Bryan Hughes" <hughesb@mindspring.com> wrote:
> Currently, whenever I start the IECC Server Agent service within the WinNT
> Services window, the CPU Usage in the Task Manager rockets up to 100%.
> When I looked to see who the culprit was, I discovered the "admagent.exe"
> process would continue to compensate for whatever CPU Usage balance was
> left. In other words, if all other processes accounted for 25% of the CPU,
> admagent.exe would adjust to 75%. If the overall processes decreased to
> 10%, then admagent.exe would rise to 90%. And so on, and so on....well, you
> get the picture.
>
> Unfortunately, this results in a bigger problem than simply a VERY slow
> server. When I open the IECC Console, Informix fails to detect the database
> server value (no blue dot). The result: Informix audit backups fail.
>
> Any suggestions or comments will be appreciated!
>
> Bryan Hughes
> Email: bhughes@med.osd.mil
>
> P.S.--If possible, please email with a response. My ability to connect to
> the Internet during the day is limited. Thanks...again!
-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own
I've seen the same problem on one of my machines. After reinstalling Informix it has been cleared up. Of course that is not a good solution for our production machine. The machine in question also had a somewhat corrupted database (crashed when deleting rows from a certain table). I second Lyzander's opinion, keep away from IECC. Just spinning that ball slows the server down. Bryan Hughes wrote: > Currently, whenever I start the IECC Server Agent service within the WinNT > Services window, the CPU Usage in the Task Manager rockets up to 100%. > > When I looked to see who the culprit was, I discovered the "admagent.exe" > process would continue to compensate for whatever CPU Usage balance was > left. In other words, if all other processes accounted for 25% of the CPU, > admagent.exe would adjust to 75%. If the overall processes decreased to > 10%, then admagent.exe would rise to 90%. And so on, and so on....well, you > get the picture. > > Unfortunately, this results in a bigger problem than simply a VERY slow > server. When I open the IECC Console, Informix fails to detect the database > server value (no blue dot). The result: Informix audit backups fail. > > Any suggestions or comments will be appreciated! > > Bryan Hughes > Email: bhughes@med.osd.mil > > P.S.--If possible, please email with a response. My ability to connect to > the Internet during the day is limited. Thanks...again!