Locale Categories
Posted in 2010
An ODBC/ASP connection to IDS 7.30 via INFORMIX-CLI 2.5 failed with "Unable to load locale categories" (error 23101) on one PC but worked on another. Advice given: the error usually means the .lco locale file matching CLIENT_LOCALE/DB_LOCALE is missing, or INFORMIXDIR is set wrongly so the locale files can't be found; locales ship with Client SDK, with extra ones in the International Language Supplement (ILS). CLIENT_LOCALE/DB_LOCALE can be set in the ODBC DSN string. The poster's database turned out to use the default en_US.819, and connections worked from ilogin32 but not from ASP; no confirmed resolution is recorded.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Connectivity: ODBC / JDBC / .NET, Internationalization & Character Sets
Hi I am getting the following error Microsoft OLE DB Provider for ODBC Drivers error '80004005' [INTERSOLV][ODBC Informix driver][Informix]Unable to load locale categories. I am currently running IDS7.30. I am attempting to setup an ODBC connection using INFORMIX-CLI 2.5 (32 Bit). I have tried this on 2 different machines, one works and the other doesn't. The difference between the 2 is that one pc is ont the same ip range as the informix server and the other is not. I have tried setting the CLIENT_LOCALE and the DB_LOCALE, with no success. Just one question on this though, can the be set at login time or should they be set at bootup. Any assistance would be highly appreciated. Thank You Andrus
Hi Andrus, I've seen this error (23101 - Unable to load locale categories) when a locale file (.lco file) corresponding to the CLIENT_LOCALE/DB_LOCALE value was missing in the installation. The following link explains in detail what files to look for. https://www.ibm.com/developerworks/mydeveloperworks/blogs/idsteam/tags/-23101?la ng=en Regarding, where to set the CLIENT_LOCALE and DB_LOCALE, it can be set in the ODBC, DSN string. For e.g: informix:host=abc.xyz.com ;service=11111;database=mydb;protocol=onsoctcp;server=myserv;CLIENT_LOCALE=ja_JP .UTF8;DB_LOCALE=ja_JP.932; Regards, Sumanth. On Wed, Apr 7, 2010 at 3:03 AM, ANDRUS CONSTANTINOU < aconstantinou@responsegroup.ie> wrote: > Hi > > I am getting the following error > > Microsoft OLE DB Provider for ODBC Drivers error '80004005' > > [INTERSOLV][ODBC Informix driver][Informix]Unable to load locale > categories. > > I am currently running IDS7.30. I am attempting to setup an ODBC connection > using INFORMIX-CLI 2.5 (32 Bit). I have tried this on 2 different machines, > one works and the other doesn't. The difference between the 2 is that one > pc > is ont the same ip range as the informix server and the other is not. > > I have tried setting the CLIENT_LOCALE and the DB_LOCALE, with no success. > Just one question on this though, can the be set at login time or should > they > be set at bootup. > > Any assistance would be highly appreciated. > Thank You > Andrus > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --001636b144f39130550483a97f21
Hi Sumanth Thanks for that, do you have any idea where I can the lco files for Ireland. Andrus
Client SDK should have them. --EEM > -----Original Message----- > From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of > ANDRUS CONSTANTINOU > Sent: Thursday, April 08, 2010 8:14 AM > To: ids@iiug.org > Subject: Re: Locale Categories [19567] > > Hi Sumanth > > Thanks for that, do you have any idea where I can the lco files for > Ireland. > > Andrus > > > *********************************************************************** > ******** > Forum Note: Use "Reply" to post a response in the discussion forum.
Hi Andrus, If you don't have the required locale files in your Informix product installation, then you can get additional locales in the Informix International Language Supplement (ILS) product. Regards, Sumanth. On Thu, Apr 8, 2010 at 6:14 AM, ANDRUS CONSTANTINOU < aconstantinou@responsegroup.ie> wrote: > Hi Sumanth > > Thanks for that, do you have any idea where I can the lco files for > Ireland. > > Andrus > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --00163630f6735ef9160483c7932b
Hi Andrus,
the error you're seeing can sometimes be caused by incorrect INFORMIXDIR
setting so LCO files can't be found. That said, are you sure you need special
locale settings for Ireland? The default character/code set, en_US.819, should
have all you need. Unless you're i18n-ising your app and going with UTF-8.
Can you please post the locale in which you database is created? When you fire
up dbaccess, Database -> Info -> (choose the db) -> Nls will tell you that.
Regards
Davorin
Hi Davorin You are correct, the database info shows NLS Capabilities and Attributes en_US.819 Collating Sequence en_US.819 CType Is there a setting on my server that is stopping me from accessing the database. I can connect using the ilogin 32 demo app but cant using an asp app. Any help please Thanks Andrus
Has cdotnet.sql been executed on the server? --EEM > -----Original Message----- > From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of > ANDRUS CONSTANTINOU > Sent: Friday, April 09, 2010 10:54 AM > To: ids@iiug.org > Subject: Re: Locale Categories [19586] > > Hi Davorin > > You are correct, the database info shows > NLS Capabilities and Attributes > > en_US.819 Collating Sequence > > en_US.819 CType > Is there a setting on my server that is stopping me from accessing the > database. > I can connect using the ilogin 32 demo app but cant using an asp app. > > Any help please > > Thanks > > Andrus > > > *********************************************************************** > ******** > Forum Note: Use "Reply" to post a response in the discussion forum.
On Thu, Apr 8, 2010 at 06:25, Everett Mills <Everett.Mills@nationalbeef.com>wrote: > Client SDK should have them. > > --EEM > > > -----Original Message----- > > From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of > > ANDRUS CONSTANTINOU > > Sent: Thursday, April 08, 2010 8:14 AM > > > > Thanks for that, do you have any idea where I can the lco files for > > Ireland. > Not sure whether you got the answer mentioning 'International Language Supplement' or ILS yet. However, that's where locales not distributed with the base products are provided. -- Jonathan Leffler #include <disclaimer.h> Email: jleffler@earthlink.net, jleffler@us.ibm.com Guardian of DBD::Informix v2008.0513 -- http://dbi.perl.org/ "Blessed are we who can laugh at ourselves, for we shall never cease to be amused." NB: Please do not use this email for correspondence. I don't necessarily read it every week, even. --0016e6d3e903026bb204848b204d