RE: Help with SQL Error -648
Posted in 1997
Michael We had this problem recently with Informix 7.14. As informix we could = open the DEBUG FILE, however as anybody else (even users with DBA = priveledges on the database) it would give us this error. We called = Informix Tech Support and they advised us to reinstall. Even though we = were sure that there was nothing wrong with the installation (we had = followed the TE(N) rule) we did and the problem went away. HTH Sujit Pal ---------- From: Nils Myklebust[SMTP:Nils.Myklebust@idg.no] Sent: Wednesday, September 03, 1997 1:29 PM To: informix-list@rmy.emory.edu Subject: Re: Help with SQL Error -648 michael_erickson@iname.com.nospam (Michael J. Erickson) wrote: :I'm having problems with the following SPL in informix 7.23.uc1 on = hp-ux=20 :10.20, but it seems to work fine on informix 7.22.uc1 on hp-ux 10.10 : :CREATE PROCEDURE test_spl( ) : :DEFINE Test_Message CHAR(50); : :set debug file to '/tmp/proc.debug'; :trace on; : :LET Test_Message =3D 'Test Message'; : :SYSTEM '/bin/echo hello'; : :End Procedure :; : :There are two problems both I belive are caused by the same thing. : :First the Debug gives me SQLCODE -648 ISAM Code -13 Permission denied. finderr 648 -648 Cannot open DEBUG file for stored procedure trace. An error occurred trying to open DEBUG trace file. This can happen when one of the directories in the specified debug file name does not exist, or the directory is write-protected. Make sure that the directory path is valid and that group informix is able to write to the directory. Other than the above the proc.debug file may allready exist in the /tmp directory and not be writeable as whatever user the debug statement is executed. :Second SYSTEM command gives SQLCODE -668 ISAM Code -13 Permission = denied. I don't know why you got permission denied if that is what isam code -13 means on your platform. However where do you expect the output of the echo to go? Particularly when you are executing from some client. You might want to try someting like: :SYSTEM '/bin/echo hello > /tmp/systemtest'; : :These errors only occur if you are running from a client system and are = :not connecting as informix. May be you created the proc.debug file while you where runing as user informix on the server? :If anyone has an idea about what this may be, I would like to here from = :them. Not much, but may be... Nils.Myklebust@idg.no NM Data AS, P.O.Box 9090 Gronland, N-0133 Oslo, Norway My opinions are those of my company The Informix FAQ is at http://www.iiug.org