Re: Increasing RAM Problems
Posted in 1999
Ok. I don't remember to have such problems, but I would check
some possible sources of problems:
1. First of all, as Art sugested, you should check your
memory chips are good.
2. I would check again the kernel parameters setting, as
SCO OpenServer as I remember modifies some of them when
you are adding more memory. But since you've said that after
removing memory chips Informix server is working well it is not
very likely that this is the problem. But you could try checking
them for compliance with release notes recomendations.
3. I'd check the BIOS settings to see the SHADOWING of BIOS, Video
is disabled, since many versions of SCO OpenServer doesn't like
these features.
4. I'd check all patches recomended for this OpenServer release
are installed, at least those related to memory problems (sory,
I don't remember there were such patches or not).
Hope somebody in the newsgroup will have more ideas.
Best Regards,
Octav
On Tue, Aug 10, 1999 at 12:25:50PM +0400, Nikolai Rybakov wrote:
> Thanks to : bayati@tmcso.com, Art S. Kagel, com@netinfo-moldova.com
>
> I have problems when I increased RAM from 64MB to 128MB;
> Here are more details:
>
> Operating System: SCO Open Server 5.04d + 25 Users License + SMP Support;
> DBMS: Informix-Online Dynamic Server 7.23 UC1;
> Hardware: Dual Intel Pentium 133 MHz;
>
> informix.log looks like:
>
> 08:45:36 Event alarms enabled. ALARMPROG =
> '/oms/InformixOn/etc/log_full.sh'
> 08:45:39 DR: DRAUTO is 0 (Off)
> 08:45:40 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 08:45:40 Physical Recovery Started.
> 08:45:40 Physical Recovery Complete: 0 Pages Restored.
> 08:45:40 Logical Recovery Started.
> 08:45:43 Logical Recovery Complete.> 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 08:45:43 Dataskip is now OFF for all dbspaces
> 08:45:43 On-Line Mode
> 08:45:43 Checkpoint Completed: duration was 0 seconds.
> 08:46:10 Assert Failed: Internal Error - Segmentation Violation
> 08:46:10 Who: Session(17, sumenk@ats301, 1586, -2109331148)
> Thread(38, sqlexec, 824421f4, 3)
> 08:46:10 Results: OnLine must abort
> 08:46:10 Action: Reinitialize shared memory
> 08:46:10 See Also: /tmp/af.2274b0, shmem.267412.0
> 08:46:17 rsinit.c, line 9949, thread 38, proc id 1515, Segmentation
> Violation.
> 08:46:17 PANIC: Attempting to bring system down>
> Here is file /tmp/af.2274b0:
>
> 08:46:48
> 08:46:48 Assert Failed: Internal Error - Segmentation Violation
> 08:46:48 Who: Session(7, sumenk@ats301, 2006, -2109332608)
> Thread(34, sqlexec, 82440cc8, 3)
> 08:46:48 Results: OnLine must abort
> 08:46:48 Action: Reinitialize shared memory
> 08:46:48 See Also: /tmp/af.2274b0, shmem.2274b0.0
> 08:46:48 Stack for thread: 34 sqlexec>
> base: 0x8263c014
> len: 36864
> pc: 0x00274801
> tos: 0x826445e8
>
> 0x8264464c ***unknown*** (0x8257d028, 0x825ec938, 0x43e4b8, 0x82440cc8)
> 0x0027422e mt_affail (0x8259e6e4, 0x8247ec10, 0x82571fe0,
> 0x82440cc8)
> 0x0019f295 rsam_affail (0x8259e6e4, 0x8247ec10, 0x82571fe0,
> 0x82440cc8)
> 0x000104f7 hang_thread (0x402644, 0x8259e6e4, 0xb, 0x82644eec)
> 0x000103bf afsig_segv (0xb, 0x0, 0x0, 0x1f)
> 0x003a81ac sigismember (0x825ecd24, 0x825ec938, 0x825ed304, 0x825ec350)
> 0x000f2af2 sel2cb (0x825ecd24, 0x825ec350, 0x0, 0x0)
> 0x000f25ff qblk2cb (0x825ecd5c, 0x825ec350, 0x825ec350,
> 0x82644f84)
> 0x000edaf2 stmt2cb (0x825ecd7c, 0x825ec350, 0x0, 0x484af8)
> 0x000ed962 p_sp2cb (0x825ecd7c, 0x825ec350, 0x0, 0x1)
> 0x000c1b95 parsecmd (0x1, 0x400884, 0x4819a0, 0x1)
> 0x000c1804 sqcmd (0x1, 0x0, 0xc, 0x1)
> 0x000c16bc sq_cmnd (0x0, 0x484d0c, 0xa, 0x8259e0b4)
> 0x000d11a3 sqmain (0x0, 0x0, 0x0, 0x0)
> 0x0025eeb8 startup (0x25, 0x82645060, 0x8263c000, 0x4c)
>
> 0x00000000 ***unknown***
>
>
> 08:46:48
> ------------------ End of assertion failure 0 -----------------
>
> Here is onconfig file:
>
> #**************************************************************************
> #
> # INFORMIX SOFTWARE, INC.
> #
> # Title: onconfig.301
> # Description: INFORMIX-OnLine Configuration Parameters
> #
> #**************************************************************************
>
> # Root Dbspace Configuration
>
> ROOTNAME rootdbs # Root dbspace name> ROOTPATH /dev/online_root # Path for device containing root dbspace
> ROOTOFFSET 0 # Offset of root dbspace into device
> (Kbytes)
> ROOTSIZE 240000 # Size of root dbspace (Kbytes)>
> # Disk Mirroring Configuration Parameters
>
> MIRROR 0 # Mirroring flag (Yes = 1, No = 0)
> MIRRORPATH # Path for device containing mirrored root
> MIRROROFFSET 0 # Offset into mirrored device (Kbytes)>
> # Physical Log Configuration
>
> PHYSDBS rootdbs # Location (dbspace) of physical log
> PHYSFILE 3000 # Physical log file size (Kbytes)>
> # Logical Log Configuration
>
> LOGFILES 6 # Number of logical log files
> LOGSIZE 5000 # Logical log size (Kbytes)>
> # Diagnostics
>
> MSGPATH /oms/InformixOn/online.log # System message log file path
> CONSOLE /dev/console # System console message path
> ALARMPROGRAM /oms/InformixOn/etc/log_full.sh # Alarm program path>
> # System Archive Tape Device
>
> TAPEDEV /dev/rStp0 # Tape device path
> TAPEBLK 16 # Tape block size (Kbytes)
> TAPESIZE 1200000 # Maximum amount of data to put on tape
> (Kbytes)>
> # Log Archive Tape Device
>
> LTAPEDEV /dev/rStp0 # Log tape device path
> LTAPEBLK 16 # Log tape block size (Kbytes)
> LTAPESIZE 1200000 # Max amount of data to put on log tape
> (Kbytes)>
> # Optical
>
> STAGEBLOB ,1 # INFORMIX-OnLine/Optical staging area
>
> # System Configuration
>
> SERVERNUM 0 # Unique id corresponding to a OnLine> instance
> DBSERVERNAME online_301 # Name of default database server
> DBSERVERALIASES shmem_301 # List of alternate dbservernames
> DEADLOCK_TIMEOUT 60 # Max time to wait of lock in distributed
> env.
> RESIDENT 1 # Forced residency flag (Yes = 1,
> No = 0)
>
> MULTIPROCESSOR 1 # 0 for single-processor, 1 for> multi-processor
> NUMCPUVPS 2 # Number of user (cpu) vps
> SINGLE_CPU_VP 0 # If non-zero, limit number of cpu vps to> one
>
> NOAGE 0 # Process aging
> AFF_SPROC 0 # Affinity start processor
> AFF_NPROCS 0 # Affinity number of processors>
> # Shared Memory Parameters
>
> LOCKS 2000 # Maximum number of locks
> BUFFERS