Wierd SE/Transaction errors-What's happening?
Posted in 1995
Having just added transactions to an SE (5.0?) with 4gl (4.11) engine
running on SCO UNIX 3.2v4.1, I am now getting error messages.
After taking out the
transaction BEGIN/COMMIT/ROLLBACK WORK statements, all works fine, with
the obvious exception that I don't have transaction support anymore.
Error 1:
Program stopped at "arpost.4gl", line number 321.
SQL statement error number -211.
Cannot read system catalog (sysdepend) .
SYSTEM error number -24.
Too many open files
Hit any key to Continue
Error 2:
Program stopped at "arpost.4gl", line number 284.
SQL statement error number -271.
Could not insert new row into the table.
SYSTEM error number -121.
ISAM error: cannot write log record.
Both of these errors happen after a number of records have already been
inserted and updated, with not particularly evident number of records
being modified before it gives an error.
In the kernel, NFILES is at 600, NOFILES is at 60, and according to a
`sar -v` these limits are not even close to being reached. The logfile
has 777 permissions (nice insecure system) and transactions have worked
before. There has been at lease 13MB available on the smallest filesystem
when these were executed.
In addition, the database applied these changes, even though the program
crashed out and no COMMIT WORK statement was ever executed. I was under
the impression that a program that crashes or otherwise exits without
COMMITting the work automatically does a ROLLBACK. Is this wrong?
I'm at a loss. Any help from the gurus? (guri?)
Thanks Muchly,
- Brian G.
--
Sometimes you're the bug, sometimes you're the windshield.