Re: Can't connect to database - Unknown error message 84
Posted in 2009
Dear Informixers, thanks to all of you who contributed to my case. It is now solved. It turned out that there were several factors that in their combination caused my problem, or made tracking it down difficult: 1) Apparently, my last password changes were not propagated by AD's "Services for Unix" to the NIS password map. So NIS still had my old password, and this was used by IDS. 2) As a remnant from our experiments with PAM, the Linux server on which IDS is residing still seems to be configured for PAM/LDAP authentication, in parallel to NIS. That is why I was able to logon to the server using my new password. Fernando led me on the right track: I tried to logon to the OS using my old password, and to my great surprise, that was successful. Now I knew that there must be two mechanisms in parallel for user authentication in the OS. Then I reset my password through the MMC "AD Users and Computers" plugin, so I wasn't forced to change it. After a while, this new password was propagated through NIS, and now I can connect to IDS using this password. So the OS and IDS are in sync again. The "unknown error message 84" remains a mystery, but that's not relevant any more. Case closed. Regards, Richard