Re: Solaris tuneable parameters
Posted in 1998
In article <362E3A9D.EFD6C36F@connix.com>, thami@connix.com (Tom Hamilton)
wrote:
> I am running SE 5.10 on an Sun E250 with Solaris 2.6 HW 5/98 (256
> Mb's). When running my application I get an
> SQL error -255. Tech support for my application said I should be> increasing my tunable parameters for max file locks,
> max file descriptors, number of processes per user, and number of
> processes per system. I have been able to increase
> the file descriptor and increased maxusers to 512 (which also affects
> max processes/system and max process/user) however
> I stilll am getting the error. Does anyone have an idea of what the
> parameter is to increase the max file locks under Solaris?
> Also, how high should I able to set maxusers? Should I be increasing it
> by 10's, 100's, 1000's? Thanks
>
> Tom Hamilton
>
>
maxusers is set to 2-3 less than the physical memory in MB, the minimum is
8 and the maximum default value is 1024. However, the maximum can be
increased in /etc/system to 2048. It is unlikely that you would need to
set this.
There are only two user tuneable parameters for the filesystem,
ufs_inode = max_nprocs + 16 + maxusers + 64
ncsize = max_nprocs + 16 + maxusers + 64
where max_nprocs is derived from maxusers (10 + (16*maxusers))
You can tell if you are overrunning these parameters at a system level
using sar -v and look in the ov column
The system imposes a per-process soft limit on open files (OPEN_MAX
defined in limits.h) to 64, which can be increased and a per-process hard
limit (usually 1024) which can not be increased. THe soft limit can be
controled from the shell using the limit (csh) command or the ulimit (sh
or ksh). If the program still refuses to start then configure the limit
with in the login process.
Paul Watson # I don't suffer from
WF Software Ltd. # stress, I'm just
Tel. (+44) 1436 674729 # a carrier
Fax. (+44) 1436 678693 #
www.wfsoftware.co.uk