Re: onmode could not block server. (Why?)
Posted in 2005
Hi,
I assume that the server in question really didn't get blocked, right ?
(That's why I asked for the status header line of "onstat -m" output
(or "onstat -" ouput) to be sure, but that's missing in your e-mail ...).
It seems likely that you've run into known problem PTS-B 169120.
It has exactly this effect that you are seeing.
Though the underlying cause for PTS-B 169120 is that a chunk or
dbspace is down and therefore the blocking does not work.
Please check your chunks and dbspaces ("onstat -d" output).
PTS-B 169120 has been fixed in 9.40.UC6 (and 9.40.FC6), i.e.
it will no longer print the confusing message into the online log
if actually the blocking didn't work.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
owner-informix-list@iiug.org wrote on 16.02.2005 00:01:03:
> Hi!
>
> I tried once again and now it worked, but this was with another server
> (presto2) on the same UNIX system
>
> Informix@S0221849> onmode -c block
> Informix@S0221849> onstat -
>
> IBM Informix Dynamic Server Version 9.40.FC3 -- On-Line -- Up
> 07:41:04 -- 70> 656 Kbytes
> Blocked:ARCHIVE
>
> Informix@S0221849> onmode -c unblock
> Informix@S0221849> onstat -
>
> IBM Informix Dynamic Server Version 9.40.FC3 -- On-Line -- Up
> 07:42:10 -- 70> 656 Kbytes
>
> The server (presto1) for which "onmode -c block" didn't succeed is
> currently offline. It was brought offline by me earlier today after
> the failed "onmode -c block" test. I have deported it's Veritas disk
> group and imported it on another UNIX system for other tests. I can
> access it's online log though and you can see an excerpt from it
> below:
>
> 04:54:17 On-Line Mode>
> Tue Feb 15 15:09:05 2005
>
> 15:09:05 Dynamic Server blocked.
> 15:09:33 Checkpoint Completed: duration was 0 seconds.
> 15:09:33 Checkpoint loguniq 9356, logpos 0xd0b018, timestamp:
> -306321810
>
> 15:09:33 Maximum server connections 0
> 15:09:33 Dynamic Server blocked.
> 15:11:34 Checkpoint Completed: duration was 0 seconds.
> 15:11:34 Checkpoint loguniq 9356, logpos 0xd0c018, timestamp:
> -306321773
>
> 15:11:34 Maximum server connections 0
> 15:11:50 Dynamic Server blocked.
> 15:14:40 Checkpoint Completed: duration was 0 seconds.
> 15:14:40 Checkpoint loguniq 9356, logpos 0xd0d018, timestamp:
> -306321734
>
> 15:14:40 Maximum server connections 0
> 15:14:40 Dynamic Server blocked.>
> Though the online log says "Dynamic Server blocked." the server put
> out "onmode could not block server." in the terminal window. Nothing
> indicates that a backup was going on at the time.
>
> Well, I will look for ongoing backups if a "onmode -c block" fails
> again. If "onmode -c block" fails again and a backup is not occuring
> at the same time I will report it here.
>
> Regards Christian Eriksson
>
>
> Martin Fuerderer <MARTINFU@de.ibm.com> wrote in message
news:<1108494652.c48e8868f3434d4c4be2131baf1d93db@teranews>...
> > Hi,
> >
> > any messages in the server's message log ?
> > Output of "onstat -m" (including the status header line) ?
> >
> > Regards,
> > Martin
> > --
> > Martin Fuerderer
> > IBM Informix Development Munich, Germany
> > Information Management
> >
> > owner-informix-list@iiug.org wrote on 15.02.2005 15:28:10:
> > > Hi!
> > >
> > > I want to block the server with "onmode -c block" and then sync and
> > > detach a plex in Veritas Volume Manager. I have a problem with
> > > blocking the server:
> > >
> > > Informix@S0221849> onstat -V
> > > IBM Informix Dynamic Server Version 9.40.FC3 Software Serial
> > > Number AAA#B000
> > > 000
> > > Informix@S0221849> onmode -c block
> > > onmode could not block server.
> > > Informix@S0221849> cat /etc/release
> > > Solaris 9 9/04 s9s_u7wos_09 SPARC
> > > Copyright 2004 Sun Microsystems, Inc. All Rights
Reserved.
> > > Use is subject to license terms.
> > > Assembled 29 June 2004
> > > Informix@S0221849> uname -a
> > > SunOS S0221849 5.9 Generic_117171-07 sun4us sparc FJSV,GPUS
> > >
> > > Why do I get "onmode could not block server."?
> > >
> > > /Christian Eriksson
> >
> > sending to informix-list
sending to informix-list