Re: Informix 7.2Se and ADO from Vb
Posted in 1999
Hi, I'll try that, but I haven't got a copy of the program avaialble. In the meantine I've worked round it by executing begin work commit/rollback work pairs. cheers MIchael Oussama MKaabal <oussama@isg.co.il> wrote in message news:7gp1pm$63c$1@news.netvision.net.il... > Hi, > according to the error you got > > -2147168248 = > in HEX its 0x8004d008 > which means XACT_E_ISOLATIONLEVEL > meaning you are truing to work with an isolation level that is not supported/or > higher than what the driver ...(databse) supports. > my guss is still you don't have the wright setting on the database but to be > sure ... > > if you have odbctest program that comes with the odbcsdk try connecting to the > ODBCDSN that you give in the connecting string to the "MSDASQL.1" provider .. > and the get into the menus and and chose connection(conn) > > and get info or SQLGetInfo for the parameter SQL_TXN_CAPABLE > and thsi will tell you what level of transaction orf isolation level > > > Oussama > > Michael Muir-Browe <Michael@nospam.truecs.force9.co.uk> wrote in message > news:5mDX2.1195$%x.1037@wards... > Hi, > > The database supports transactions and the provider is "MSDASQL.1". > > The chap I am looking into this for is converting a vb3 application to vb6 > and in the process he is attempting to convert the database.begintrans... to > their ado equivalents > > connection.begintrans this results in a error stating that:- > > -2147168248 Neither the isolation level or a stregthening of it can be > supported. > > I will be testing the transactions by executing native begintrans > committrans pairs. > > > cheers > > MIchael > > > Oussama MKaabal <oussama@isg.co.il> wrote in message > news:7gmkc8$emu$1@news.netvision.net.il... > > Hi , > > > > in order to give you an answer i need to know more ... > > 1) who is youre ADO(OLE-DB) provider ... or are you working throught > Kagira > > through ODBC ... > > > > things to check ... > > 1) can you sork or start transactions not through ADO... maybe your > database is > > not set to to work with transactions ... > > if not refere to your administration guid on setting the database > in > > transaction Mode ... > > > > 2) else check if your provider supports transactions ... > > > > Michael Muir-Browe <Michael@nospam.truecs.force9.co.uk> wrote in message > > news:%RyX2.1179$%x.986@wards... > > Hi Anyone out there using ADO with Infromix Se ? We are having problem > with > > begintrans failing > > > > cheers > > > > Michael > > > > > > > > > > > >