Re: infdump
Posted in 2006
Topics: Server Administration
madh wrote: > what about the parameter in onconfig dumpshmem. > > is it responsible for this shared memory dump. > > in manual i found that if dumpshmem is set 1 then it will dump > shared memory for every startup and shutdown. > > do we need to set this. i request you to give some suggestions > regarding this The manual does say the parameter takes effect on server start up or shut down (it would probably be more accurate to say that changes to its value only take effect when the server is restarted - because that's when the ONCONFIG file is reparsed). The manual (Admin's Ref) also says: DUMPSHMEM indicates that shared memory should be dumped on an assertion failure. So, shared memory only is dumped when an assertion failure occurs. The original question suggested that they were getting a dump on server shutdown; that should not be happening. If there isn't already an explanation here in c.d.i, then contact Tech Support. If you don't have Tech Support, get it. -- Jonathan Leffler #include <disclaimer.h> Email: jleffler@earthlink.net, jleffler@us.ibm.com Guardian of DBD::Informix v2005.02 -- http://dbi.perl.org/
couldn't we at least ask him for a tiny snippet of his online.log - maybe there's more wisdom in such file than you might imagine. Tip: set MSGPATH (in onconfig) to ... ... and don't forget to restart the engine ;-)