Alter table in replication
Posted in 2016
Topics: General Discussion
Hi, I need to alter a table that is in a replication. First I use the "cdr alter --on table", to can alter the table, but when I try to alter it, I get the 26482 error. What can I do ? Thanks in advance. Enviado desde mi iPhone
Hello, Jorge. If the error description is right, you should be inside an ER grid. In that case, before your execute the command, you should have being connected to the grid, forwarding the command to all ER nodes. -26482 Cannot alter a replicated table in a grid outside of the same grid context The ALTER TABLE statement on a replicated table that was created through a grid must be executed within the same grid context and with replication enabled by setting the ER_enable argument to 1. Hope it helps. Best regards. Alexandre Marini IBM Informix Certified Professional v10 / v11.50 / v11.70 / v12.10 IBM Information Management Informix Technical Professional IBM Certified Developer - Informix Genero BRIUG website administrator Informix independent consultant > To: ids@iiug.org > From: jorgervt@gmail.com > Subject: Alter table in replication [36419] > Date: Tue, 19 Jan 2016 12:30:03 -0500 > > Hi, > > I need to alter a table that is in a replication. First I use the "cdr alter > --on table", to can alter the table, but when I try to alter it, I get the > 26482 error. > > What can I do ? > > Thanks in advance. > > Enviado desde mi iPhone > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. >
How can I connect to the grid ?. I meant Im inside OAT, I believe I'm already connected. Enviado desde mi iPhone > El 19/01/2016, a las 10:03 a.m., Alexandre Marini <alexandre@briug.org> escribió: > > Hello, Jorge. > If the error description is right, you should be inside an ER grid. > In that case, before your execute the command, you should have being connected > to the grid, forwarding the command to all ER nodes. > > -26482 Cannot alter a replicated table in a grid outside of the same grid > context > > The ALTER TABLE statement on a replicated table that was created through > a grid must be executed within the same grid context and with > replication enabled by setting the ER_enable argument to 1. > > Hope it helps. > Best regards. > > Alexandre Marini > IBM Informix Certified Professional v10 / v11.50 / v11.70 / v12.10 > > IBM Information Management Informix Technical Professional > > IBM Certified Developer - Informix Genero > BRIUG website administrator > Informix independent consultant > >> To: ids@iiug.org >> From: jorgervt@gmail.com >> Subject: Alter table in replication [36419] >> Date: Tue, 19 Jan 2016 12:30:03 -0500 >> >> Hi, >> >> I need to alter a table that is in a replication. First I use the "cdr alter >> --on table", to can alter the table, but when I try to alter it, I get the >> 26482 error. >> >> What can I do ? >> >> Thanks in advance. >> >> Enviado desde mi iPhone > ******************************************************************************* >> Forum Note: Use "Reply" to post a response in the discussion forum. > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. >
To alter replicated table in flexible grid environment, following=20
procedure needed to be executed within the session before altering=20
replicated grid table.
execute procedure ifx=5Fgrid=5Fconnect('grid1',1);
grid1 in the above command is the grid name. Second argument '1' enables=20
grid to update replicate definitions.
This below redbook has details on flexible grid with examples.
http://www.redbooks.ibm.com/redbooks/SG247937/wwhelp/wwhimpl/js/html/wwhelp=
.htm
Thanks & Regards,
Nagaraju
From: "Jorge Valenzuela" <jorgervt@gmail.com>
To: ids@iiug.org
Date: 01/19/2016 01:11 PM
Subject: Re: Alter table in replication [36421]
Sent by: ids-bounces@iiug.org
How can I connect to the grid ?. I meant Im inside OAT, I believe I'm=20
already=20
connected.=20
Enviado desde mi iPhone=20
> El 19/01/2016, a las 10:03 a.m., Alexandre Marini <alexandre@briug.org>=20
escribi=F3:=20
>=20
> Hello, Jorge.=20
> If the error description is right, you should be inside an ER grid.=20
> In that case, before your execute the command, you should have being=20
connected=20
> to the grid, forwarding the command to all ER nodes.=20
>=20
> -26482 Cannot alter a replicated table in a grid outside of the same=20
grid=20
> context=20
>=20
> The ALTER TABLE statement on a replicated table that was created through =
> a grid must be executed within the same grid context and with=20
> replication enabled by setting the ER=5Fenable argument to 1.=20
>=20
> Hope it helps.=20
> Best regards.=20
>=20
> Alexandre Marini=20
> IBM Informix Certified Professional v10 / v11.50 / v11.70 / v12.10=20
>=20
> IBM Information Management Informix Technical Professional=20
>=20
> IBM Certified Developer - Informix Genero=20
> BRIUG website administrator=20
> Informix independent consultant=20
>=20
>> To: ids@iiug.org=20
>> From: jorgervt@gmail.com=20
>> Subject: Alter table in replication [36419]=20
>> Date: Tue, 19 Jan 2016 12:30:03 -0500=20
>>=20
>> Hi,=20
>>=20
>> I need to alter a table that is in a replication. First I use the "cdr=20
alter=20
>> --on table", to can alter the table, but when I try to alter it, I get=20
the=20
>> 26482 error.=20
>>=20
>> What can I do ?=20
>>=20
>> Thanks in advance.=20
>>=20
>> Enviado desde mi iPhone=20
>=20
***************************************************************************=
****=20
>> Forum Note: Use "Reply" to post a response in the discussion forum.=20
>=20
>=20
>=20
***************************************************************************=
****=20
> Forum Note: Use "Reply" to post a response in the discussion forum.=20
>=20
***************************************************************************=
****=20
Forum Note: Use "Reply" to post a response in the discussion forum.=20
The problem was resolved.
It was an error with Informix, I only had to restart the instance (onmode -ky
, oninit) and all works well.
Thanks very much.
Enviado desde mi iPhone
> El 25/01/2016, a las 11:38 a.m., Nagaraju Inturi <nagaraju@us.ibm.com>
escribió:
>
> To alter replicated table in flexible grid environment, following=20
> procedure needed to be executed within the session before altering=20
> replicated grid table.
>
> execute procedure ifx=5Fgrid=5Fconnect('grid1',1);>
> grid1 in the above command is the grid name. Second argument '1' enables=20
> grid to update replicate definitions.
>
> This below redbook has details on flexible grid with examples.
>
> http://www.redbooks.ibm.com/redbooks/SG247937/wwhelp/wwhimpl/js/html/wwhelp=
> ..htm
>
> Thanks & Regards,
> Nagaraju
>
> From: "Jorge Valenzuela" <jorgervt@gmail.com>
> To: ids@iiug.org
> Date: 01/19/2016 01:11 PM
> Subject: Re: Alter table in replication [36421]
> Sent by: ids-bounces@iiug.org
>
> How can I connect to the grid ?. I meant Im inside OAT, I believe I'm=20
> already=20
> connected.=20
>
> Enviado desde mi iPhone=20
>
>> El 19/01/2016, a las 10:03 a.m., Alexandre Marini <alexandre@briug.org>=20
> escribi=F3:=20
>> =20
>> Hello, Jorge.=20
>> If the error description is right, you should be inside an ER grid.=20
>> In that case, before your execute the command, you should have being=20
> connected=20
>> to the grid, forwarding the command to all ER nodes.=20
>> =20
>> -26482 Cannot alter a replicated table in a grid outside of the same=20
> grid=20
>> context=20
>> =20
>> The ALTER TABLE statement on a replicated table that was created through =
>
>> a grid must be executed within the same grid context and with=20
>> replication enabled by setting the ER=5Fenable argument to 1.=20
>> =20
>> Hope it helps.=20
>> Best regards.=20
>> =20
>> Alexandre Marini=20
>> IBM Informix Certified Professional v10 / v11.50 / v11.70 / v12.10=20
>> =20
>> IBM Information Management Informix Technical Professional=20
>> =20
>> IBM Certified Developer - Informix Genero=20
>> BRIUG website administrator=20
>> Informix independent consultant=20
>> =20
>>> To: ids@iiug.org=20
>>> From: jorgervt@gmail.com=20
>>> Subject: Alter table in replication [36419]=20
>>> Date: Tue, 19 Jan 2016 12:30:03 -0500=20
>>> =20
>>> Hi,=20
>>> =20
>>> I need to alter a table that is in a replication. First I use the "cdr=20
> alter=20
>>> --on table", to can alter the table, but when I try to alter it, I get=20
> the=20
>>> 26482 error.=20
>>> =20
>>> What can I do ?=20
>>> =20
>>> Thanks in advance.=20
>>> =20
>>> Enviado desde mi iPhone=20
>> =20
> ***************************************************************************=
> ****=20
>
>>> Forum Note: Use "Reply" to post a response in the discussion forum.=20
>> =20
>> =20
>> =20
> ***************************************************************************=
> ****=20
>
>> Forum Note: Use "Reply" to post a response in the discussion forum.=20
>> =20
>
> ***************************************************************************=
> ****=20
>
> Forum Note: Use "Reply" to post a response in the discussion forum.=20
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>