error 206
Posted in 2011
Topics: Connectivity: ODBC / JDBC / .NET, Server Administration, Security, Permissions & Auditing
hi to all
i created a database with ansi logging, the purpose is the manage the access
with the grant/revoke instructions.
when i'm on the server locally with dbaccess the rights work well, granted
users can do only the statements thats they are allowed for.
but i try to get a table with odbc connection on access ou excel, with the
same users, i have the 206 error, the table is not in the database
help me please :)
On Sun, Jan 16, 2011 at 4:55 PM, SMITH JOHN <daylight@webmails.com> wrote:
> hi to all
>
> i created a database with ansi logging, the purpose is the manage the
> access
> with the grant/revoke instructions.
>
> when i'm on the server locally with dbaccess the rights work well, granted
> users can do only the statements thats they are allowed for.
>
> but i try to get a table with odbc connection on access ou excel, with the
> same users, i have the 206 error, the table is not in the database
>
> help me please :)
>
>
> On ANSI databases you must prefix the tablenames with the owner if the user
is not the owner...
Are you doing that? Do you have DELIMIDENT environment variable defined in
the client?
SELECT * FROM "owner".tabname;
Regards
--
Fernando Nunes
Portugal
http://informix-technology.blogspot.com
My email works... but I don't check it frequently...
--0015174be17afabfc60499fabc13
yes, i prefix the tablename with the owner when i'm on the server machine, and
using dbaccess. it works well.
but the problem is that i'm using microsoft excel or access, on a windows
machine, to access the table with odbc, so when i'm connected i can see the
names of the tables prefixed with the user but there's not quotes (user.table
not "user".table). and when i select the wanted table i see the 206 error
message.