db/log backup failure
Posted in 2008
Topics: Logging & Checkpoints, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi, Can someone please throw some insight what happens when database backup fails or log fails on the client side with the message "aborted by client"? How it impacts the database users in application. We backup database and logs in dataprotector/omniback and sometime due to hardware issues backup or log fails. At that very moment is it possible that users may not be able to do any DML via application? One of our developer thinks that might be the case when log/db backup fails, informix does not allow any update, delete etc for that minute although database looks normal. We use tomcat/apache as app server and apparently they lose connection with database for that moment. Can someone please confirm that if that can be the case and if there is a remedy to avoid that situation? Our platform is: IDS 10.0 FC7 HP-UX 11.11 Appserver tomcat/apache backup media dataprotector/omniback Your asap response will be highly appreciated. Thanks, Sunita Raina
Hi, no. There should not be a direct impact on user activity if a backup operation fails. When a dbspace backup is started, a checkpoint is done, and this may uphold users a bit - until the checkpoint has gone through. But if that is the case you should see in your message log (onconfig parameter MSGPATH) that there was a checkpoint with long duration (i.e. longer than 10 seconds). But I don't know how a backup failure would block users from doing their transactions. If logical logs are not backed up at all, then they will eventually become all full and cannot be overwritten before they got backed up. In that situation the instance will grind to a halt - but that doesn't seem to be the scenario with your system. Regards, Martin -- Martin Fuerderer IBM Informix Development Munich, Germany Information Management IBM Deutschland Entwicklung GmbH Chairman of the Supervisory Board: Martin Jetter Board of Management: Herbert Kircher Corporate Seat: Boeblingen, Germany Reg.-Gericht: Amtsgericht Stuttgart, HRB 243294 ids-bounces@iiug.org wrote on 01.04.2008 16:16:10: > Hi, > > Can someone please throw some insight what happens when database backup fails > or log fails on the client side with the message "aborted by client"? How it > impacts the database users in application. We backup database and logs in > dataprotector/omniback and sometime due to hardware issues backup or log > fails. At that very moment is it possible that users may not be ableto do any > DML via application? One of our developer thinks that might be the case when > log/db backup fails, informix does not allow any update, delete etc for that > minute although database looks normal. We use tomcat/apache as app server and > apparently they lose connection with database for that moment. Can someone > please confirm that if that can be the case and if there is a remedyto avoid > that situation? > > Our platform is: > IDS 10.0 FC7 > HP-UX 11.11 > Appserver tomcat/apache > backup media dataprotector/omniback > > Your asap response will be highly appreciated. > > Thanks, > Sunita Raina > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > See you at the IIUG Informix 2008 Conference > The Power Conference for Informix Professionals > April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas > http://www.iiug.org/conf > Registration Now Open!!
SUNITA RAINA wrote: > Hi, > > Can someone please throw some insight what happens when database backup fails > or log fails on the client side with the message "aborted by client"? How it > impacts the database users in application. We backup database and logs in > dataprotector/omniback and sometime due to hardware issues backup or log > fails. At that very moment is it possible that users may not be able to do any > DML via application? One of our developer thinks that might be the case when > log/db backup fails, informix does not allow any update, delete etc for that > minute although database looks normal. We use tomcat/apache as app server and > apparently they lose connection with database for that moment. Can someone > please confirm that if that can be the case and if there is a remedy to avoid > that situation? > Martin is correct. There's nothing about the cleanup following a failed archive or logical log backup that would cause any session to lose its connection to the server. The ONLY thing that might affect performance would be the dropping of the temp tables (one per dbspace not yet completed by the archive). This might cause some minor IO bandwidth issues if there were a VERY high transaction volume during the time the archive was running before it failed. More likely whatever caused the archive itself to fail also affected the app servers. Victims of the same problem. Art S. Kagel Oninit > Our platform is: > IDS 10.0 FC7 > HP-UX 11.11 > Appserver tomcat/apache > backup media dataprotector/omniback > > Your asap response will be highly appreciated. > > Thanks, > Sunita Raina > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > See you at the IIUG Informix 2008 Conference > The Power Conference for Informix Professionals > April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas > http://www.iiug.org/conf > Registration Now Open!! > > >