Re: 2ND TRY: Why do I get an SQL error -242 with an ISAM error of 0?
Posted in 1994
Daniel Wood writes: |> I have run into a problem where I get an SQL error of -242 which is |> "Could not open database table (<TBLNAME>)" from a select statement. |> The ISAM error is 0 which gives no indication as to why the table |> could not be opened. |> |> It seems to happen when ispnopen() sees the tablespace flag of 0x20 set |> in the tablespace slot in shared memory. |> |> The On-Line Administrator's Guide does not document the flag 0x20 in |> the section on "tbstat -t". What is this flag? It indicates that the tblspace in question is a temp table (at least in 5.X). Dave Disclaimer: The opinions expressed in this message are not those of Informix Software, its partners or lackeys. Anyone who says otherwise is itching for a fight. **************************************************************************** "I look back with some satisfaction on what an idiot I was when I was 25, but when I do that, I'm assuming I'm no longer an idiot." - Andy Rooney