Re: dbexport bug
Posted in 1995
> I noticed a fastidious bug in dbexport utility. If you place a comment
> after the SP name, dbexport badly fails the generated sql script!!, so
> you can't re-import it correctly.
Yes, this bug exists even in 7.10.UC1. My workaround is to write
4gl report, wich does procedures unloading using system catalog
tables.
There is another bad thing: if your procedure use any views,
dbimport would fail. The reason is that dbexport generates views
texts after procedures texts. It's strange, because server
itself permits procedure creating if tables or views it used not
exists yet. I have to edit an entire generated sql-script
carefully, because views cannot be created before tables exists,
synonyms or privileges cannot exists before views and tables
created, plus, sql-script itself is too big for any of my editors
(it may be 3Mb about), uhh... It's tedious!
Yours,
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
. Igor G.Popov . Laboratory of Open Information Systems, ltd. .
. res@lois.perm.su . Russia, Perm, b. Gagarina 49, +7-3422-486374 .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .