Re: shared memory already exists
Posted in 1999
Obnoxio The Clown — — source: Informix-list mailing list archive (1991-1998)
> I am getting the following error when I tried to initialize one of my >instances. > >shmget:[EEXIST][17]: key 52564801:shared memory already exists >mt_shm_init:cant' create resident segemnt. > >Someone please let me know how t fix this. I'd say you had a crash or didn't shut down properly. The easiest way to fix this is to reboot the machine. The more complicated way is to use ipcs to show you any shared memory segments and semaphores, then calculate which ones refer to your instance, then remove them using ipcrm. Rebooting is much simpler and probably safer (if your maths is anything like mine! :-) ______________________________________________________ Get Your Private, Free Email at http://www.hotmail.com