LOAD FROM error handling
Posted in 1999
Topics: Server Administration
Hi,
when I do a LOAD FROM filename INTO table and one of the records
to be imported fails (because of a non-unique key value, say) - how
do I tell Informix that it should continue importing the rest of
the file? I'm using dbaccess.
Thanks,
Frederik
--
Frederik Ramm (frederik@remote.org)
You should use the dbload command with the -e # (the # is the number
of errors to allow before abort).
Frederik Ramm wrote:
> Hi,
>
> when I do a LOAD FROM filename INTO table and one of the records
> to be imported fails (because of a non-unique key value, say) - how
> do I tell Informix that it should continue importing the rest of
> the file? I'm using dbaccess.
>
> Thanks,
> Frederik
>
> --
> Frederik Ramm (frederik@remote.org)
Another possible solution (apart from "dbload")
could be the use of a violation table:
you could set your constraints and indexes to mode 'filtering without
error'
and create a violation table for the table to load the data in.
After loading the data into your table you have to analyze possible
corrupted data in the violation table. Checking the diagnostic data
which
is created for EVERY error in every line (in contrast to 'dbload') will
help you to repair/report the cause of error.
Just an idea,
Christian Brauer