Re: remote tape with ontape (dd command) fail afte
Posted in 2008
On Thu, Mar 13, 2008 at 5:58 AM, Guillermo Gómez Valcárcel
<guillermo.gomez@grafia.es> wrote:
> Until now I had been archiving our database with ontape throught remote tape
> connecting to another host called gestion.
>
> The onconfig parameter is:
> TAPEDEV gestion:/dev/rmt/2
>
> Yesterday I install openssh in gestion (the tape host) and now I get dd:
> "Permission denied" when execute ontape command from another host that not
> have openssh installed.
>
> Database host: Informix Dynamic Server 9.21.UC5 Solaris 8 without openssh.
> Tape host: Solaris 7 with openssh.
>
> $ ontape -s -L 1> Please mount tape 1 on gestion:/dev/rmt/2u and press Return to continue ...
> Remote tape report:
> dd: /dev/rmt/2u: open: Permission denied
> could not write archive tape.
>
> Any remote command with dd works without problems:
>
> $ rsh gestion "dd if=/var/tmp/graficos_1999.txt" >
> /var/tmp/graficos_1999.txt> 89+1 records in
> 89+1 records out
>
> But ontape doesn't. dd fail with Permission denied.
>
> What can I do?
> Uninstall on tape host?
> Install openssh on database host sent backup correctly?
Odd that the rsh commands work...
There's the DBREMOTECMD environment variable.
Also take a good look at permissions on the tape server machine - are
you sure the directory where the files are going have the correct
permissions?
Have you checked .rhosts files etc? Did installing SSH somehow screw that up?
No real answer - mostly just questions; sorry.
--
Jonathan Leffler #include <disclaimer.h>
Email: jleffler@earthlink.net, jleffler@us.ibm.com
Guardian of DBD::Informix v2007.0914 -- http://dbi.perl.org/
NB: Please do not use this email for correspondence.
I don't necessarily read it every week, even.