ISM will not start - waiting for daemons
Posted in 2007
Topics: High Availability & Replication, Server Administration, Platform-Specific Issues
Hello everyone! I am a new member and happy to be part of this forum.
I'm receiving the following at the command line when attempting to start ISM.
ISM was working on this server in the past:
Informix Dynamic Server 9.30.FC1
SUN 280R running Solaris 8
# ./ism_startup
ism_startup: is starting the ISM daemons.
${0##*/}: Still waiting for ISM daemons to become available...
${0##*/}: Still waiting for ISM daemons to become available...
ism_startup: ISM server not running after 2 minutes and 30 seconds.
daemon.log:
01/09/07 19:50:36 nsrd: server notice: started
01/09/07 19:50:37 nsrmmdbd: error adding btrees to ss (an invalid slot number)
01/09/07 19:50:37 nsrmmdbd: WISS error, an invalid slot number
01/09/07 19:50:37 nsrd: unable to start nsrmmdbd
01/09/07 19:50:37 nsrd: shutting down
01/09/07 19:50:37 nsrd: successful shutdown
01/09/07 19:50:38 nsrexecd: Can't initialize configuration file
/nsr/res/nsrla.res
01/09/07 19:50:38 nsrexecd: SYSTEM error, resource file /nsr/res/nsrla.res
already
in use; check for another copy of this server
already running
01/09/07 19:50:38 nsrexecd: error initializing resource file.
01/09/07 19:53:44 nsrd: server notice: started
01/09/07 19:53:45 nsrmmdbd: error adding btrees to ss (an invalid slot number)
01/09/07 19:53:45 nsrmmdbd: WISS error, an invalid slot number
01/09/07 19:53:45 nsrd: unable to start nsrmmdbd
01/09/07 19:53:45 nsrd: shutting down
01/09/07 19:53:45 nsrd: successful shutdown
Research has indicated that I may be able to fix ISM by performing the
following:
1. Renaming the mm directory
2. Redoing the ism_startup -init
3. ism_catalog -recreate_from device.
Has anyone done this? What about moving the /opt/informix9.3/ism/mm/mmvolume
directory to another name? It appears that this may have been done previously
by another DBA/admin:
/opt/informix9.3/ism/mm
# ls -l -atotal 10
drwxr-xr-x 4 root other 512 Jan 8 04:15 .
drwxr-xr-x 10 root other 512 Sep 14 2002 ..
-rw-r--r-- 1 root root 0 Dec 27 04:06 .cmprssd
-rw-r--r-- 1 root other 54 Sep 14 2002 .nsr
drwx------ 2 root root 512 Jan 9 19:53 mmvolume
drwx------ 2 root other 512 Jul 29 08:36 mmvolume.old
-rw-r--r-- 1 root other 0 Jan 8 04:15 nsrim.prv
# cd mmvolume
# ls -l -atotal 724
drwx------ 2 root root 512 Jan 9 19:53 .
drwxr-xr-x 4 root other 512 Jan 8 04:15 ..
-rw------- 1 root root 8192 Jan 9 19:53 VolHdr
-rw------- 1 root root 32768 Jan 9 19:53 ss
-rw------- 1 root root 32768 Jan 9 19:53 ss.0
-rw------- 1 root root 32768 Jan 9 19:53 vol
-rw------- 1 root root 16384 Jan 8 10:10 vol.0
-rw------- 1 root root 32768 Jan 8 10:10 vol_i0
-rw------- 1 root root 16384 Jan 8 10:11 vol_i0.0
-rw------- 1 root root 32768 Jan 8 10:11 vol_i1
-rw------- 1 root root 16384 Jan 8 10:11 vol_i1.0
-rw------- 1 root root 32768 Jan 8 10:10 vol_i2
-rw------- 1 root root 16384 Jan 8 10:11 vol_i2.0
-rw------- 1 root root 32768 Jan 8 10:10 vol_i3
-rw------- 1 root root 16384 Jan 8 10:11 vol_i3.0
-rw------- 1 root root 32768 Jan 8 10:11 vol_i4
-rw------- 1 root root 16384 Jan 8 10:11 vol_i4.0
#
Any help would be greatly appreciated.
Thanks,
Mike
Hi Mike,
this looks to me like a partially corrupted ISM file db as described very
similiar
in IBM Technote1109108.
See URL http://www-1.ibm.com/support/docview.wss?uid=swg21109108
By the way, if not already known, the IDS db release is outdated.
HTH,
Robert
Robert Seifert
_________________________________________________________________
IBM Deutschland GmbH, Software, Information Management,
Informix Products, Advanced Support
Elite VAR support engineer
Development Support for IBM Informix Products on-site @ SAP
c/o SAP AG, -PS03-,Neurottstrasse 16, D-69190 Walldorf, Germany
_________________________________________________________________
ids-bounces@iiug.org wrote on 10.01.2007 16:33:35:
>
> Hello everyone! I am a new member and happy to be part of this forum.
> I'm receiving the following at the command line when attempting to start
ISM.
> ISM was working on this server in the past:
>
> Informix Dynamic Server 9.30.FC1
> SUN 280R running Solaris 8
>
> # ./ism_startup
> ism_startup: is starting the ISM daemons.
> ${0##*/}: Still waiting for ISM daemons to become available...
> ${0##*/}: Still waiting for ISM daemons to become available...
> ism_startup: ISM server not running after 2 minutes and 30 seconds.
>
> daemon.log:
> 01/09/07 19:50:36 nsrd: server notice: started
> 01/09/07 19:50:37 nsrmmdbd: error adding btrees to ss (an invalid
> slot number)
> 01/09/07 19:50:37 nsrmmdbd: WISS error, an invalid slot number
> 01/09/07 19:50:37 nsrd: unable to start nsrmmdbd
> 01/09/07 19:50:37 nsrd: shutting down
> 01/09/07 19:50:37 nsrd: successful shutdown
> 01/09/07 19:50:38 nsrexecd: Can't initialize configuration file
> /nsr/res/nsrla.res
> 01/09/07 19:50:38 nsrexecd: SYSTEM error, resource file
/nsr/res/nsrla.res
> already
> in use; check for another copy of this server
> already running
> 01/09/07 19:50:38 nsrexecd: error initializing resource file.
> 01/09/07 19:53:44 nsrd: server notice: started
> 01/09/07 19:53:45 nsrmmdbd: error adding btrees to ss (an invalid
> slot number)
> 01/09/07 19:53:45 nsrmmdbd: WISS error, an invalid slot number
> 01/09/07 19:53:45 nsrd: unable to start nsrmmdbd
> 01/09/07 19:53:45 nsrd: shutting down
> 01/09/07 19:53:45 nsrd: successful shutdown
>
> Research has indicated that I may be able to fix ISM by performing the
> following:
>
> 1. Renaming the mm directory
>
> 2. Redoing the ism_startup -init
>
> 3. ism_catalog -recreate_from device.
>
> Has anyone done this? What about moving the
/opt/informix9.3/ism/mm/mmvolume
> directory to another name? It appears that this may have been done
previously
> by another DBA/admin:
>
> /opt/informix9.3/ism/mm
> # ls -l -a> total 10
> drwxr-xr-x 4 root other 512 Jan 8 04:15 .
> drwxr-xr-x 10 root other 512 Sep 14 2002 ..
> -rw-r--r-- 1 root root 0 Dec 27 04:06 .cmprssd
> -rw-r--r-- 1 root other 54 Sep 14 2002 .nsr
> drwx------ 2 root root 512 Jan 9 19:53 mmvolume
> drwx------ 2 root other 512 Jul 29 08:36 mmvolume.old
> -rw-r--r-- 1 root other 0 Jan 8 04:15 nsrim.prv
> # cd mmvolume
> # ls -l -a> total 724
> drwx------ 2 root root 512 Jan 9 19:53 .
> drwxr-xr-x 4 root other 512 Jan 8 04:15 ..
> -rw------- 1 root root 8192 Jan 9 19:53 VolHdr
> -rw------- 1 root root 32768 Jan 9 19:53 ss
> -rw------- 1 root root 32768 Jan 9 19:53 ss.0
> -rw------- 1 root root 32768 Jan 9 19:53 vol
> -rw------- 1 root root 16384 Jan 8 10:10 vol.0
> -rw------- 1 root root 32768 Jan 8 10:10 vol_i0
> -rw------- 1 root root 16384 Jan 8 10:11 vol_i0.0
> -rw------- 1 root root 32768 Jan 8 10:11 vol_i1
> -rw------- 1 root root 16384 Jan 8 10:11 vol_i1.0
> -rw------- 1 root root 32768 Jan 8 10:10 vol_i2
> -rw------- 1 root root 16384 Jan 8 10:11 vol_i2.0
> -rw------- 1 root root 32768 Jan 8 10:10 vol_i3
> -rw------- 1 root root 16384 Jan 8 10:11 vol_i3.0
> -rw------- 1 root root 32768 Jan 8 10:11 vol_i4
> -rw------- 1 root root 16384 Jan 8 10:11 vol_i4.0
> #
>
> Any help would be greatly appreciated.
>
> Thanks,
>
> Mike
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
Robert: Thank you for the URL to the IBM Tech Note. It did resolve my issue with ISM not starting. It also cleared another post I had regarding a sysmaster sql statement that would not complete. I am planning to upgrade to IDS 9.4/10 in the future. Thanks, Mike