Re: Level 0 Archive Restore over TCP/IP
Posted in 1994
In article <2pgebl$ot6@uuneo.neosoft.com> stone@news.NeoSoft.com writes: > In my attempt to automate as much work as possible, I wanted to ask if anyone > has tried to do a LEVEL 0 ARCHIVE RESTORE to a mirrored system on my network > over TCP/IP? I would greatly appreciate anyones comments or sugestions to > get this underway. Thanks :) > > Stoner > > Oh yes. Well you didn't say what platform but I can tell that I have had one or two problems with this. I use SCO on 486's. This is the problem that I had. Machine 1 is and ALR powerpro running Online V4 and I-Star. I back up daily to a dat drive on this machine. I have had occasion to use the tapes in a restore and (touch wood) they have so far worked. I then got a second machine and a 1 user licence, This machine has an identical tape drive. Now, there are two ways to go. Back up on machine 1 IMHO should be done first. Then you can either a) Restore that archive over the net to the engine on machine 2 or b) BackUp accross the net to the tape on machine 2, and then restore that backup on machine 2. The advantage of (b) is that you get two archive tapes, covering the potential problem of media error. The problem is that I could not get (b) to work. The first backup goes ok. The second back apppears to go ok. However the engine on machine (b) consistently refused to restore the archive created across the net. If says that it cannot restore chunk 0 ( which of course does not exist). Informix dialed into my system and failed to diagnose the problem, even after taking a copy of a few megs of my tape. So I have to use method (a). After the cross network restore I am going to try to do a local backup on (b) from b's engine and then try and restore that. As far as doing it is concerned it's quite easy. You can use the environment variable TBCONFIG to point to a different configuration file. That can point the tape device to the remote machine. Or you can just create a file on the remote machine that signifies that the first backup is complete and it can now take over. Or use rsh or .......... Hope this all helps. All IMHO of course :-) -- Clive Eisen Email ceisen@deepthwt.demon.co.uk Clive Eisen Computing Phone (+44) 71 281 1414