Re: Online Initialization Problems on RAID Machine
Posted in 1995
In article <3kpg51$fpu@sol.cms.uncwil.edu> rlong@sol.cms.uncwil.edu (Robbie Long) writes:
>
>I have an NCR 3525 with RAID level 5. NCR(AT&T) Unix sys Vr4 version 2.03.01
>
>I'm trying to install ONLINE version 5.03.UC1. The box says that this
>online is for use on NCR UNIX version 2.03
>
>The problem is that when I try to initialize I get the following errors.
>ON THE SCREEN I get the following:
>
>tbinit: fatal error in shared memory initialization
>
>IN THE ONLINE.LOG I get the following:
>
>17:52:42 I/O error 'read': expect 2048 actual -1 addr 0x0 errno 6 retrys 0
>17:52:42 I/O error 'read': expect 2048 actual -1 addr 0x0 errno 6 retrys 1
>17:52:42 I/O error, Primary Chunk '/dev/rdsk/c21t5d1s1' -- Offline
>17:52:42 I/O read() chunk 1, pagenum 0, pagecnt 1 --> errno = 6
>17:52:42 INFORMIX-OnLine Must ABORT> Root chunk down.
>17:52:42 -- Online Aborting -- us=400024bc, pid=2241, uid=108
>17:52:42 INFORMIX-OnLine Stopped>
>
This happened to us over here. The problem was that Informix was writing
over the label. Give informix the entire disk after an offset of x kb
where x is OS dependent. On Solaris 10K is enough..
in your onconfig file if root is the first partition on disk
ROOTOFFSET 10
should do the job..
Burzin
--
--
Burzin N. Engineer |Tel. (310) 524 1800 | email: burzin@twinsun.com
Twin Sun Inc. |Fax. (310) 524 1818 | MIME OkaY!