Archchecker on IDS version 11.50.FC6
Posted in 2010
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL, Licensing & Editions, Platform-Specific Issues, Versions, Editions & End-of-Life
Hello,
Anyone out there having issues with table level restore for enterprise
replicated tables on IDS 11.50.FC6 running on AIX 5.30?
Command file is:
database zodiac;
CREATE TABLE zodmoney_money_breakout (
network SMALLINT NOT NULL,
pin INT8 NOT NULL,
insert_date DATETIME YEAR TO FRACTION(3)
DEFAULT CURRENT YEAR TO FRACTION(3),
amount_type CHAR(1) NOT NULL,
original_amount MONEY(7,2) NOT NULL,
amount_left MONEY(7,2) NOT NULL,
promo_flag CHAR(1)
) with CRCOLS IN dbs1;
CREATE TABLE zodmoney_money_breakout_restore (
network SMALLINT NOT NULL,
pin INT8 NOT NULL,
insert_date DATETIME YEAR TO FRACTION(3)
DEFAULT CURRENT YEAR TO FRACTION(3),
amount_type CHAR(1) NOT NULL,
original_amount MONEY(7,2) NOT NULL,
amount_left MONEY(7,2) NOT NULL,
promo_flag CHAR(1)
) with CRCOLS IN dbs1;
insert into zodmoney_money_breakout_restore select
network,pin,insert_date,amount_type,original_amount,amount_left,promo_flag
from zodmoney_money_breakout;
restore to '2010-07-05 05:00:00';
command used is :
archecker -bXvs -f /tmp/zodiac.cmd
Getting this in the ac_msg.log
informix @ ibm46:/tmp: cat ac_msg.log
2010-07-06 17:16:21
-----------------------------------------
STATUS: IBM Informix Dynamic Server Version 11.50.FC6
Program Name: archecker
Version: 8.0
Released: 2009-12-15 22:53:46
CSDK: IBM Informix CSDK Version 3.50
ESQL: IBM Informix-ESQL Version 3.50.FC4
Compiled: 12/15/09 22:54 on AIX 3 5
STATUS: Arguments [-bXvs -f /tmp/zodiac.cmd]
STATUS: AC_STORAGE /tmp
STATUS: AC_MSGPATH /tmp/ac_msg.log
STATUS: AC_VERBOSE on
STATUS: AC_TAPEBLOCK 60 KB
STATUS: AC_IXBAR /wic/informix/etc/ixbar.46
STATUS: AC_SCHEMA /tmp/zodiac.cmd
TIME: [2010-07-06 17:16:22] All old validation files removed.
STATUS: Dropping old log control tables
ERROR: "Prepare (cur_clean_rsc_dicts)" failed
ERROR: -217: (rgetlmsg() returned -1227)
ERROR: "Declaring (cur_clean_rsc_dicts)" failed
ERROR: -481: (rgetlmsg() returned -1227)
ERROR: "Openning (cur_clean_rsc_dicts_cursor)" failed
ERROR: -404: (rgetlmsg() returned -1227)
ERROR: "Fetching (cur_clean_rsc_dicts_cursor)" failed
ERROR: -400: (rgetlmsg() returned -1227)
ERROR: "DROP TABLE ÿÿÿÿÿêà" failed
ERROR: -202: (rgetlmsg() returned -1227)
ERROR: "Fetching (cur_clean_rsc_dicts_cursor)" failed
ERROR: -400: (rgetlmsg() returned -1227)
Using default ac_config.std
#**************************************************************************
#
# Licensed Material - Property Of IBM
#
# "Restricted Materials of IBM"
#
# IBM Informix Dynamic Server
# (c) Copyright IBM Corporation 1996, 2004 All rights reserved.
#
# Title: ac_config.std
# Description:
# Default ac_config.std for archecker archive utility
#
#**************************************************************************
AC_MSGPATH /tmp/ac_msg.log # archecker message log
AC_STORAGE /tmp # Directory used for temp storage
AC_VERBOSE 1 # 1 verbose messages 0 terse messages
It seems to work fine for non-replicated tables. I have also tried it using a
work-around creating the table with explicitly creating the shadow columns and
mapping the selected columns, same results.
Hello.
I also had some troubles using archecker with onbar, but your schema file
seems allright.
Other related troubles here were solved issuing the parameters:
AC_TAPEDEV [your onbar device]
AC_TAPEBLOCK 62 KB
AC_LTAPEDEV [your onbar device]
AC_LTAPEBLOCK 62 KB
But our errors were different, It´s just a guess, ok?
Worth trying???
Best Regards.