Informix response time very slow when DNS is down.
Posted in 2004
Topics: Server Administration, Networking & sqlhosts Configuration
We are currently running Informix Version 7.31.FC2 - Unix 11.0.
We have two DNS servers located on separate devices. Our main server
connects to these DNS servers. When either of these DNS servers is shut
down, i.e. maintenance, the informix server responds slowly , i.e 1 - 2
minutes for a response. Any ideas how to get informix to look at the second
DNS more responsively or to remove the maintenance DNS from the informix
lookup. We have already tried changing resolv.conf, but has no effect on
informix database.
We do have two instances on the informix server. This issue only affects
instance1. Not instance2. The sqlhosts file is setup to use ip only. Sample
follows.
Sample SQL Hosts
instance1 onsoctcp 10.10.12.2 sqlexec_4
instance2 onsoctcp 10.10.12.2 sqlexec_5
Sample Service
sqlexec_4 1444/tcp
sqlexec_5 1444/tcp
Error Message in Informix Log
11:48:17 listener-thread: err = -25580: oserr = 232: errstr = : System
error occurred in network function. System error = 232.
11:55:17 listener-thread: err = -25573: oserr = 233: errstr = : Network
driver cannot accept a connection on the port. System error = 233.
Any ideas of where to look to resolve this issue is greatly appreciated.
Linda Cole
Dba
Primus Canada
----------------------------------------------------------------------------
This electronic message contains information from Primus Telecommunications
Canada Inc. ("PRIMUS") , which may be legally privileged and confidential.
The information is intended to be for the use of the individual(s) or entity
named above. If you are not the intended recipient, be aware that any
disclosure, copying, distribution or use of the contents of this information
is prohibited. If you have received this electronic message in error, please
notify us by telephone or e-mail (to the number or address above)
immediately. Any views, opinions or advice expressed in this electronic
message are not necessarily the views, opinions or advice of PRIMUS.
It is the responsibility of the recipient to ensure that
any attachments are virus free and PRIMUS bears no responsibility
for any loss or damage arising in any way from the use
thereof.The term "PRIMUS" includes its affiliates.
----------------------------------------------------------------------------
Pour la version en français de ce message, veuillez voir
http://www.primustel.ca/fr/legal/cs.htm
----------------------------------------------------------------------------
Linda Cole said: > Any ideas of where to look to resolve this issue is greatly appreciated. /etc/resolv, ironically. :o) Put the IP addresses of your database servers into /etc/hosts, and then make sure that the order of resolution in /etc/resolv is hostfile then DNS. -- Bye now, Obnoxio "C'est pas parce qu'on n'a rien à dire qu'il faut fermer sa gueule" - Coluche "I'm trying to see things your way, but I can't get my head up my ass" - JCH "Ogni uomo mi guarda come se fossi una testa di cazzo" - Marco I went to the airport to check in and they asked what I did because I looked like a terrorist. I said I was a comedian. They said, "Say something funny then." I told them I had just graduated from flying school. -- Ahmed Ahmed
Why do you
have both instances using the same port? They need to talk on two different
ports. Try changing sqlexec_5 to 1445 if that is not already used in the
/etc/services file. Do it while instance2 is down then bring it back up again.
I'm supprised that doesn't cause you problems in many situations, not just
when the DNS server is down.
K
-----Original Message-----
From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On Behalf
Of Linda Cole
Sent: Friday, December 10, 2004 12:43 PM
To: ids@iiug.org
Subject: Informix response time very slow when DNS is down. [3872]
We are currently running Informix Version 7.31.FC2 - Unix 11.0.
We have two DNS servers located on separate devices. Our main server connects
to these DNS servers. When either of these DNS servers is shut down, i.e.
maintenance, the informix server responds slowly , i.e 1 - 2 minutes for a
response. Any ideas how to get informix to look at the second DNS more
responsively or to remove the maintenance DNS from the informix lookup. We
have already tried changing resolv.conf, but has no effect on informix
database.
We do have two instances on the informix server. This issue only affects
instance1. Not instance2. The sqlhosts file is setup to use ip only. Sample
follows.
Sample SQL Hosts
instance1 onsoctcp 10.10.12.2 sqlexec_4
instance2 onsoctcp 10.10.12.2 sqlexec_5
Sample Service
sqlexec_4 1444/tcp
sqlexec_5 1444/tcp
Error Message in Informix Log
11:48:17 listener-thread: err = -25580: oserr = 232: errstr = : System error
occurred in network function. System error = 232. 11:55:17 listener-thread:
err = -25573: oserr = 233: errstr = : Network driver cannot accept a
connection on the port. System error = 233.
Any ideas of where to look to resolve this issue is greatly appreciated.
Linda Cole
Dba
Primus Canada
----------------------------------------------------------------------------
This electronic message contains information from Primus Telecommunications
Canada Inc. ("PRIMUS") , which may be legally privileged and confidential. The
information is intended to be for the use of the individual(s) or entity named
above. If you are not the intended recipient, be aware that any disclosure,
copying, distribution or use of the contents of this information is
prohibited. If you have received this electronic message in error, please
notify us by telephone or e-mail (to the number or address above) immediately.
Any views, opinions or advice expressed in this electronic message are not
necessarily the views, opinions or advice of PRIMUS. It is the responsibility
of the recipient to ensure that any attachments are virus free and PRIMUS
bears no responsibility for any loss or damage arising in any way from the use
thereof.The term "PRIMUS" includes its affiliates.
----------------------------------------------------------------------------
Pour la version en français de ce message, veuillez voir
http://www.primustel.ca/fr/legal/cs.htm
----------------------------------------------------------------------------