Re: invalid row id...
Posted in 1997
In article <01bc6418$7ab1da00$f1c893cf@bat-computer>, benedict de guzman
<bdguz@worldnet.att.net> writes
>In the process of running a data load, we always encounter an assert
>failure message that there was an invalid row id, where a record is read.
>What does this mean? It also specified a 'partnum' and it was pointing to a
>certain hierarchy table. How can we identify which record had the invalid
>row id? Was this caused by garbage in the data being loaded? How can we
>prevent this from occuring again? We are using Informix On-line Server
>version 7.20 on a
>HP-UX 10.10. Thanks for any help.
Try running the following oncheck commands:-
oncheck -cr
oncheck -ce
oncheck -cc <database name>
oncheck -cID <database name>
and see if you get any errors.
If so unload the table then drop then table and recreate it...
or restore from an uncorrupted archive..
--
David Williams