Re: SQL.IEM -324
Posted in 1998
Hi Thank you for using Openlink Software From what I understand, this power failure for some reason has stopped you from being able to link more than two tables in Access. What happens when you try to do a Pass-through query in Access with a join in the tables. The .iem file as you may well know is the Informix error message file and has this flie been corrupted in any way and what are the permissions on that file? With regards the error you are getting, it denotes an Ambiguous column name. 'A column name shown appears in more than one table listed in the FROM clause in the query. The database server needs to be told which of the columns to use. When you link your tables, are they prefixed by a table name and secondly, are you trying a manual link? Please let me know how you get on. Best Regards Emmon Simbo Openlink Software J Jacobs wrote: > > To my astute colleagues, > > I have tried and plundered my way through this and have not been able to > come up with a solution to my problem. This post will be 'winded' but I > hope all the info is needed for you to help is provided. I thank you in > advance. > > I'm getting the following error on the Cliend: > > ODBC-call failed. Cannot open file 'sql.iem' (-324)(#-324) (OPL)Syntax > error or access(#0). > > Client Configuration: MS Windows NT Workstation 4.0 > MS Access Version 2.00 (I know - I > know!!!) > OpenLink for Win32 V 1.00.0000 > Provider info (In > OpenLink): Type: Informix 5 > > Protocol: TCP/IP > > ------------------------ > > Server Configuration: SCO Unix V386 Release 3.2 > $INFORMIXDIR=/usr/tools/informix-5.01 > (/usr/tools/informix-5.01/msg/sql.iem: DOES EXIST) > > ------------------------- > More facts: The error only arises on the PC Client when trying to join 2 > tables > on the Server. > This error sproatically occurs on 1 PC but ALWAYS on a > 2nd PC. > There's no problem 'opening' a query that reads 1 > table from the > Server. > OpenLink has been re-installed on the PC where the > problem is > ALWAYS occuring. > When the 2-table query works on the 1 PC, the > read/write head > on the Client goes nuts-o for 10 seconds and > eventually returns > the data. > BOTH Clients have been re-booted a plethera of times. > The Server has been re-booted 2x's so far. > Running the 2-table query on the Server, directly, > works just fine. > ------------------------ > My theory: None at this time. I don't know why 1 PC has a problem ALL > the time and why a 2nd PC only has it sporatically. BTW, the 2nd PC > gets sometimes got a shared violation error but that stopped when I shut > all other applications down on it. No code has changed on the Client > side or the Server side in about 1-1/2 years! And lastly, we had a > power failure on Friday, the 20th. Before that, BOTH Clients worked > fine! But when we came in on Monday, and ever since, neither PC works > right. > > I appreciate anyone's indulgence on this one. > > Sincerely, > J Jacobs