Re: Onbar backup problems
Posted in 2005
Topics: Backup & Restore, Storage & Space Management, Server Administration
Hi, I don't know about Windows things, but I've a few ideas: - I'm not sure how you are starting ON-Bar and what you mean by "Data Protector". "Data Protector" may be part of a storage manager. But it looks like the error is produced by ON-Bar. I do not really believe in the "signal 154" part of the "DP"-message, but the rest looks plausible. - with ON-Bar error 0x9a (154) has the following meaning: BAR_NO_PERMISSION 0x9a /* (154) not root,informix or NT admin*/ So this can easily be caused by a missing configuration step when you moved from one system to the other. - did you check the ON-Bar activity log ? (For the filename check your BAR_ACT_LOG onconfig parameter.) It may contain more descriptive information, leading to the root cause. - if nothing else helps, you can turn on ON-Bar debug-tracing by setting onconfig file parameter BAR_DEBUG to a value higher than 0 (higher value means more tracing output with 9 being the maximum. You may want to start with a value of 3 or 4). Also set the onconfig file parameter BAR_DEBUG_LOG to a valid filename. This is where the debug-trace output will be written to. In the output then look for the error number ("154" and/or "0x9a"). Regards, Martin -- Martin Fuerderer IBM Informix Development Munich, Germany Information Management owner-informix-list@iiug.org wrote on 18.03.2005 01:44:17: > We are experiencing a very strange problem with Data Protector. Last > weekend we moved our SAP production system from a Windows NT server to a > brand new Windows 2000 server. > > When we launch our backups, if we try to run a parallel backup, Data > Protector just takes the first 8 dbspaces and after backing them up, aborts > the backup. If we run a whole backup (-w), the process finishes without > errors. > > When we were using the NT server, we didnt have any problems. > > The error that DP shows is: > 2005-03-14 13:43:58 3600 3208 The ON-Bar process 1636 exited with a > problem (exit code 154 (0x9a), signal 154). > > We checked all the permissions and they are correct. We have tried several > things, but DP always backs up only 8 dbspaces. > > Any ideas ? > > Thanks > > -- > Message posted via http://www.dbmonster.com sending to informix-list
Data Protector is HP's backup manager, the artefact formally known as Omniback. It has superb integration for Informix redolent of the heady days of onarchive ;-) "Martin Fuerderer" <MARTINFU@de.ibm.com> wrote in message news:1111149646.386901e76ea4f9ed08b7085c176b2221@teranews... > > Hi, > > I don't know about Windows things, but I've a few ideas: > > - I'm not sure how you are starting ON-Bar and what you mean by > "Data Protector". "Data Protector" may be part of a storage manager. > But it looks like the error is produced by ON-Bar. I do not really > believe > in the "signal 154" part of the "DP"-message, but the rest looks > plausible. > > - with ON-Bar error 0x9a (154) has the following meaning: > BAR_NO_PERMISSION 0x9a /* (154) not root,informix or NT admin*/ > So this can easily be caused by a missing configuration step when > you moved from one system to the other. > > - did you check the ON-Bar activity log ? > (For the filename check your BAR_ACT_LOG onconfig parameter.) > It may contain more descriptive information, leading to the root cause. > > - if nothing else helps, you can turn on ON-Bar debug-tracing by > setting onconfig file parameter BAR_DEBUG to a value higher than 0 > (higher value means more tracing output with 9 being the maximum. > You may want to start with a value of 3 or 4). > Also set the onconfig file parameter BAR_DEBUG_LOG to a valid > filename. This is where the debug-trace output will be written to. > In the output then look for the error number ("154" and/or "0x9a"). > > Regards, > Martin > -- > Martin Fuerderer > IBM Informix Development Munich, Germany > Information Management > > owner-informix-list@iiug.org wrote on 18.03.2005 01:44:17: > > We are experiencing a very strange problem with Data Protector. Last > > weekend we moved our SAP production system from a Windows NT server to a > > brand new Windows 2000 server. > > > > When we launch our backups, if we try to run a parallel backup, Data > > Protector just takes the first 8 dbspaces and after backing them up, > aborts > > the backup. If we run a whole backup (-w), the process finishes without > > errors. > > > > When we were using the NT server, we didnt have any problems. > > > > The error that DP shows is: > > 2005-03-14 13:43:58 3600 3208 The ON-Bar process 1636 exited with a > > problem (exit code 154 (0x9a), signal 154). > > > > We checked all the permissions and they are correct. We have tried > several > > things, but DP always backs up only 8 dbspaces. > > > > Any ideas ? > > > > Thanks > > > > -- > > Message posted via http://www.dbmonster.com > > sending to informix-list
Hi Martin: Data Protector is the tool we use as Storage Manager for backing up our Informix Database. On-Bar documentation shows return code 154 as permission problems but we?re not convinced about it. If we backup individually or in groups of 8 any of the dbspaces it works without a problem. The whole database backup work fine too. In case of permission problems both scenarios shouldn?t be workig, should they ? We set debug for a session and the error showed is the one I sent you in the first message. The error message in BAR_ACT.log file has the same return code. We?ve checked out informix user and related gruops permissions and they seem to be correct. It?s a very strange problems and we haven?t found further documentation about the error. Thanks -- Message posted via http://www.dbmonster.com
Martin, After doing several tests with the onconfig parameters, we found that the only way that the backup would run was to define the BAR_MAX_BACKUP variable with a number different than 0. Is there anything documented on this issue ? We are running Windows 2000 Advance Server and we configured it so it could take more than 2GB of memory using the /3G and /PAR parameters. And do you know what would be an optimal number for the BAR_MAX_BACKUP parameter? Thanks !! -- Message posted via http://www.dbmonster.com