problem dropping databases
Posted in 1995
When I try to drop a database (as user informix)
I get the errors listed at the bottom of this
post. I'm baffled because, there is definitely
no one using this database, but informix differs.
My rootdbs has been filled up by users long gone
who have stored this stuff and I need to get rid
of it ASAP. I would very much appreciate any
email regarding how I might approach this problem
Thanks!
Carol L. Stimmel
-------------------------
? drop database esql_demo
214: Cannot remove file for table (syscolumns).
106: ISAM error: non-exclusive access.
Error in line 1Near character position 23
finderr 214 produces:
-214 Cannot remove file for table table-name.
Something prevents the database server from completely removing
the table shown. Check the accompanying ISAM error code for more
information. Typical causes involve problems with operating
system file permissions, read-only files, and hardware errors.
finderr 106 produces:
-106 ISAM error: non-exclusive access.
The ISAM processor has been asked to add or drop an index when it
does not have exclusive access. C-ISAM programs: Before doing this
operation the file must be opened with exclusive access. Review the
program logic and make sure it opens this file passing the
ISEXCLLOCK flag to isopen. SQL products: This error can be
returned on the INFORMIX-OnLine Dynamic Server or the
INFORMIX-SE database server when an exclusive lock is required on
a table. For example, this error appears when a second user tries to
alter a table that has been locked by the first user.
--
Carol
*********************************************************
Carol L. Stimmel NOAA/ERL/FSL
Systems Analyst stimmel@fsl.noaa.gov
*********************************************************