[HELP]Informix Dynamic Server got errors!!
Posted in 1999
Topics: Versions, Editions & End-of-Life
Dear all.
Our server (Informix IDS 7.31 TC2)got an error that no any connection can
connect to the server.
When I issue the onstat - command, it prompt the server is in the On-line
Mode, but when I issue
onstat -m command, I found many same errors like this:<xxx>connection reject - no calls allowed for sqlexec
listener-Thread:err = -27002: oserr= 0: errstr = : No Connections
are allowed in
Dynamic Server quiescent mode.
Please help me! It's really hurry and serious!
Paul,
Did the error occur before the engine went to online mode? It could simply
mean that some of your network clients tried to connect to engine before it
went online.
paul wrote:
> Dear all.
> Our server (Informix IDS 7.31 TC2)got an error that no any connection can
> connect to the server.
> When I issue the onstat - command, it prompt the server is in the On-line
> Mode, but when I issue
> onstat -m command, I found many same errors like this:> <xxx>connection reject - no calls allowed for sqlexec
> listener-Thread:err = -27002: oserr= 0: errstr = : No Connections
> are allowed in
> Dynamic Server quiescent mode.
> Please help me! It's really hurry and serious!
Thanks all!
I have tried the onmode -ky or onmode -m, but it did not work!
When I tried for 5 hours and almost gave up, it worked on-line
automatically!
It's really strange!
paul <paoching@panpi.com.tw> wrote in message
news:82aii6$hvb@netnews.hinet.net...
> Dear all.
> Our server (Informix IDS 7.31 TC2)got an error that no any connection can
> connect to the server.
> When I issue the onstat - command, it prompt the server is in the On-line
> Mode, but when I issue
> onstat -m command, I found many same errors like this:> <xxx>connection reject - no calls allowed for sqlexec
> listener-Thread:err = -27002: oserr= 0: errstr = : No
Connections
> are allowed in
> Dynamic Server quiescent mode.
> Please help me! It's really hurry and serious!
>
>
Paul,
You can ignore those messages. All they are telling you is that while
the engine was in the process of coming up, after the network listerner
threads had been started in fact but before the engine was in ONLINE mode,
some client tried to connect using a network connection type and was
rejected because the engine was not yet completely online. This will
happen if you have aggressive clients that are trying to connect in a
loop (setting INFORMIXCONNTIME and/or INFORMIXCONNRETRY trigger an
implicit connect loop in the ESQL library code for example) or users who
just happen to be trying to connect at the time the engine is starting up.
No worries, mate, this happens ALL THE TIME and it is meaningless. These
clients will either get a connection as soon as the engine goes (went?)
online or will timeout their loop before that happens and will try again
later.
Art S. Kagel
paul wrote:
>
> Thanks all!
> I have tried the onmode -ky or onmode -m, but it did not work!
> When I tried for 5 hours and almost gave up, it worked on-line
> automatically!
> It's really strange!
>
> paul <paoching@panpi.com.tw> wrote in message
> news:82aii6$hvb@netnews.hinet.net...
> > Dear all.
> > Our server (Informix IDS 7.31 TC2)got an error that no any connection can
> > connect to the server.
> > When I issue the onstat - command, it prompt the server is in the On-line
> > Mode, but when I issue
> > onstat -m command, I found many same errors like this:> > <xxx>connection reject - no calls allowed for sqlexec
> > listener-Thread:err = -27002: oserr= 0: errstr = : No
> Connections
> > are allowed in
> > Dynamic Server quiescent mode.
> > Please help me! It's really hurry and serious!
> >
> >