oncheck -cc errors
Posted in 2005
Topics: Installation, Setup & Upgrades, Storage & Space Management, Versions, Editions & End-of-Life
We have just upgraded from IDS 9.30.FC1X6
to IDS 9.40.FC3 and now have =
the following 'oncheck -cc' errors.
OS =3D Dec TRU64 UNIX 5.1B.
Any ideas on how to get rid of them. They do not seem to affect =
anything.
The 5000 is the correct sysindices nextsize .
Steven Willcoxon
The Shubert Organization
-----------------------------------------
Beginning Oncheck Script
Starting oncheck -cc
Mon Feb 28 09:23:17 EST 2005
Validating database sysutils
Validating systables for database sysutils
Validating syscolumns for database sysutils
Validating sysindexes for database sysutils
Validating systabauth for database sysutils
Validating syscolauth for database sysutils
Validating sysdepend for database sysutils
Validating syssyntable for database sysutils
WARNING:No syssyntable records found.
Validating sysviews for database sysutils
Validating sysconstraints for database sysutils
Validating database production
Validating systables for database production
ERROR: informix.sysindices nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysindices
Owner informix
TBLspace number b00170
Tabid 3
Row size 3307
Number of columns 14
Number of indexes 2
Number of rows 1343
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 292
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
ERROR: informix.sysconstraints nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysconstraints
Owner informix
TBLspace number b00172
Tabid 11
Row size 335
Number of columns 7
Number of indexes 3
Number of rows 5467
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 305
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
ERROR: informix.sysprocedures nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysprocedures
Owner informix
TBLspace number b00171
Tabid 16
Row size 5270
Number of columns 30
Number of indexes 3
Number of rows 859
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 174
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
Validating syscolumns for database production
Validating sysindexes for database production
Validating systabauth for database production
Validating syscolauth for database production
Validating sysdepend for database production
Validating syssyntable for database production
WARNING:No syssyntable records found.
Validating sysviews for database production
Validating sysconstraints for database production
Validating database sysmaster
Validating systables for database sysmaster
Validating syscolumns for database sysmaster
Validating sysindexes for database sysmaster
Validating systabauth for database sysmaster
Validating syscolauth for database sysmaster
Validating sysdepend for database sysmaster
Validating syssyntable for database sysmaster
WARNING:No syssyntable records found.
Validating sysviews for database sysmaster
Validating sysconst
Looks like someone changed the NEXTSIZE in the systables entry in the database
instead of using ALTER TABLE. The REAL next size is stored on the table's
partition header page or tablespace tablespace entry. Oncheck validates the one
against the other and is reporting the descrepency. Manually modifying system
catalog table records is a serious no-no and can cause severe data access
problems including loss of access to your data altogether.
Art S. Kagel
----- Original Message -----
From: Steve Willcoxon <stevew@shubertorg.com>
At: 2/28 15:02
> We have just upgraded from IDS 9.30.FC1X6 to IDS 9.40.FC3 and now have =
> the following 'oncheck -cc' errors.
> OS =3D Dec TRU64 UNIX 5.1B.
> Any ideas on how to get rid of them. They do not seem to affect =
> anything.
> The 5000 is the correct sysindices nextsize .
>
> Steven Willcoxon
> The Shubert Organization
>
>
>
> -----------------------------------------
> Beginning Oncheck Script
> Starting oncheck -cc
> Mon Feb 28 09:23:17 EST 2005
>
> Validating database sysutils
>
> Validating systables for database sysutils
>
> Validating syscolumns for database sysutils
>
> Validating sysindexes for database sysutils
>
> Validating systabauth for database sysutils
>
> Validating syscolauth for database sysutils
>
> Validating sysdepend for database sysutils
>
> Validating syssyntable for database sysutils
> WARNING:No syssyntable records found.
>
> Validating sysviews for database sysutils
>
> Validating sysconstraints for database sysutils
>
> Validating database production
>
> Validating systables for database production
> ERROR: informix.sysindices nextsize 5000 !=3D tblspace.nxtsize 8
> TBLspace name sysindices
> Owner informix
> TBLspace number b00170
> Tabid 3
> Row size 3307
> Number of columns 14
> Number of indexes 2
> Number of rows 1343
> Date created 05/14/2002
> TBLspace major version number 3
> TBLspace minor version number 127
> TBLspace type T
> Locking level R
> Number of pages used 292
> First extent size 16
> Next extent size 10000
> Flags 0
> Site =20
> Database name =20
> ERROR: informix.sysconstraints nextsize 5000 !=3D tblspace.nxtsize 8
> TBLspace name sysconstraints
> Owner informix
> TBLspace number b00172
> Tabid 11
> Row size 335
> Number of columns 7
> Number of indexes 3
> Number of rows 5467
> Date created 05/14/2002
> TBLspace major version number 3
> TBLspace minor version number 127
> TBLspace type T
> Locking level R
> Number of pages used 305
> First extent size 16
> Next extent size 10000
> Flags 0
> Site =20
> Database name =20
> ERROR: informix.sysprocedures nextsize 5000 !=3D tblspace.nxtsize 8
> TBLspace name sysprocedures
> Owner informix
> TBLspace number b00171
> Tabid 16
> Row size 5270
> Number of columns 30
> Number of indexes 3
> Number of rows 859
> Date created 05/14/2002
> TBLspace major version number 3
> TBLspace minor version number 127
> TBLspace type T
> Locking level R
> Number of pages used 174
> First extent size 16
> Next extent size 10000
> Flags 0
> Site =20
> Database name =20
>
> Validating syscolumns for database production
>
> Validating sysindexes for database production
>
> Validating systabauth for database production
>
> Validating syscolauth for database production
>
> Validating sysdepend for database production
>
> Validating syssyntable for database production
> WARNING:No syssyntable records found.
>
> Validating sysviews for database production
>
> Validating sysconstraints for database production
>
> Validating database sysmaster
>
> Validating systables for database sysmaster
>
> Validating syscolumns for database sysmaster
>
> Validating sysindexes for database sysmaster
>
> Validating systabauth for database sysmaster
>
> Validating syscolauth for database sysmaster
>
> Validating sysdepend for database sysmaster
>
> Validating syssyntable for database sysmaster
> WARNING:No syssyntable records found.
>
> Validating sysviews for database sysmaster
>
> Validating sysconst
Go into
dbaccess and change the nextsize to match what you want.
I had that "problem" too when I did 7.31 to 9.40 upgrade on sun.
Appears to be a cosmetic issue...
Of course, I did not wait to see what would happen if it actually wanted
to take the next extent....
Norma Jean
-----Original Message-----
From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On
Behalf Of Steve Willcoxon
Sent: Monday, February 28, 2005 1:51 PM
To: ids@iiug.org
Subject: oncheck -cc errors [4363]
We have just upgraded from IDS 9.30.FC1X6 to IDS 9.40.FC3 and now have =
the following 'oncheck -cc' errors.
OS =3D Dec TRU64 UNIX 5.1B.
Any ideas on how to get rid of them. They do not seem to affect =
anything.
The 5000 is the correct sysindices nextsize .
Steven Willcoxon
The Shubert Organization
-----------------------------------------
Beginning Oncheck Script
Starting oncheck -cc
Mon Feb 28 09:23:17 EST 2005
Validating database sysutils
Validating systables for database sysutils
Validating syscolumns for database sysutils
Validating sysindexes for database sysutils
Validating systabauth for database sysutils
Validating syscolauth for database sysutils
Validating sysdepend for database sysutils
Validating syssyntable for database sysutils WARNING:No syssyntable
records found.
Validating sysviews for database sysutils
Validating sysconstraints for database sysutils
Validating database production
Validating systables for database production
ERROR: informix.sysindices nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysindices
Owner informix
TBLspace number b00170
Tabid 3
Row size 3307
Number of columns 14
Number of indexes 2
Number of rows 1343
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 292
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
ERROR: informix.sysconstraints nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysconstraints
Owner informix
TBLspace number b00172
Tabid 11
Row size 335
Number of columns 7
Number of indexes 3
Number of rows 5467
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 305
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
ERROR: informix.sysprocedures nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysprocedures
Owner informix
TBLspace number b00171
Tabid 16
Row size 5270
Number of columns 30
Number of indexes 3
Number of rows 859
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 174
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
Validating syscolumns for database production
Validating sysindexes for database production
Validating systabauth for database production
Validating syscolauth for database production
Validating sysdepend for database production
Validating syssyntable for database production WARNING:No
syssyntable records found.
Validating sysviews for database production
Validating sysconstraints for database production
Validating database sysmaster
Validating systables for database sysmaster
Validating syscolumns for database sysmaster
Validating sysindexes for database sysmaster
Validating systabauth for database sysmaster
Validating syscolauth for database sysmaster
Validating sysdepend for database sysmaster
Validating syssyntable for database sysmaster WARNING:No syssyntable
records found.
Validating sysviews for database sysmaster
Validating sysconst
============================================================
The information contained in this message may be privileged
and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, or an employee
or agent responsible for delivering this message to the
intended recipient, you are hereby notified that any reproduction,
dissemination or distribution of this communication is strictly
prohibited. If you have received this communication in error,
please notify us immediately by replying to the message and
deleting it from your computer. Thank you. Tellabs
============================================================
These
next sizes were originally increased about 4 years ago (IDS 7.?) with
'ALTER TABLE ... MODIFY NEXT SIZE 10000'
for several of the sysmaster tables which had 70+ extents. We did a
'dbexport' edited the output file to add the alter tables
and then did a 'dbimport' to get the extents down to 2 for these tables.
We had no problems with all the interim IDS versions until 9.4.
Per Clifton M. Bean and Norma J. Sebastian, I ran the 'ALTER TABLE ...
MODIFY NEXT SIZE 10000'
on the three tables and that cleared the 'oncheck -cc' errors.
Thanx to all who responded,
Steven Willcoxon
The Shubert Organization
----- Original Message -----
From: "Steve Willcoxon" <stevew@shubertorg.com>
To: <ids@iiug.org>
Sent: Monday, February 28, 2005 2:50 PM
Subject: oncheck -cc errors [4363]
We have just upgraded from IDS 9.30.FC1X6 to IDS 9.40.FC3 and now have =
the following 'oncheck -cc' errors.
OS =3D Dec TRU64 UNIX 5.1B.
Any ideas on how to get rid of them. They do not seem to affect =
anything.
The 5000 is the correct sysindices nextsize .
Steven Willcoxon
The Shubert Organization
-----------------------------------------
Beginning Oncheck Script
Starting oncheck -cc
Mon Feb 28 09:23:17 EST 2005
Validating database sysutils
Validating systables for database sysutils
Validating syscolumns for database sysutils
Validating sysindexes for database sysutils
Validating systabauth for database sysutils
Validating syscolauth for database sysutils
Validating sysdepend for database sysutils
Validating syssyntable for database sysutils
WARNING:No syssyntable records found.
Validating sysviews for database sysutils
Validating sysconstraints for database sysutils
Validating database production
Validating systables for database production
ERROR: informix.sysindices nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysindices
Owner informix
TBLspace number b00170
Tabid 3
Row size 3307
Number of columns 14
Number of indexes 2
Number of rows 1343
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 292
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
ERROR: informix.sysconstraints nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysconstraints
Owner informix
TBLspace number b00172
Tabid 11
Row size 335
Number of columns 7
Number of indexes 3
Number of rows 5467
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 305
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
ERROR: informix.sysprocedures nextsize 5000 !=3D tblspace.nxtsize 8
TBLspace name sysprocedures
Owner informix
TBLspace number b00171
Tabid 16
Row size 5270
Number of columns 30
Number of indexes 3
Number of rows 859
Date created 05/14/2002
TBLspace major version number 3
TBLspace minor version number 127
TBLspace type T
Locking level R
Number of pages used 174
First extent size 16
Next extent size 10000
Flags 0
Site =20
Database name =20
Validating syscolumns for database production
Validating sysindexes for database production
Validating systabauth for database production
Validating syscolauth for database production
Validating sysdepend for database production
Validating syssyntable for database production
WARNING:No syssyntable records found.
Validating sysviews for database production
Validating sysconstraints for database production
Validating database sysmaster
Validating systables for database sysmaster
Validating syscolumns for database sysmaster
Validating sysindexes for database sysmaster
Validating systabauth for database sysmaster
Validating syscolauth for database sysmaster
Validating sysdepend for database sysmaster
Validating syssyntable for database sysmaster
WARNING:No syssyntable records found.
Validating sysviews for database sysmaster
Validating sysconst