Re: Getting error "-23101 Unable to load locale categories"...Please Help.!!
Posted in 2003
Hi Neil.
Sounds like cron does not read .login.
If you use C-shell, how about the following ?
.cshrc
#!/bin/csh
if ($?prompt == 0) exit
setenv INFORMIXDIR ....
setenv PATH {INFORMIXDIR}/bin:${PATH}setenv DB_LOCALE
setenv CLIENT_LOCALE
...
...
Regards.
--
Tsutomu Ogiwara from Tokyo Japan.
ICQ#:168106592
>From: "Neil" <triton_no1@hotmail.com>
>Reply-To: "Neil" <triton_no1@hotmail.com>
>To: informix-list@iiug.org
>Subject: Getting error "-23101 Unable to load locale categories"...Please
>Help.!!
>Date: Tue, 13 May 2003 10:24:00 +1000
>
>Hi,
>
>I currently have a sun ultra 5 running informix 7.2
>and dbaccess version 7.23.UC4
>
>I am using cron to run a script file that calls another script file that
>contains the following command.
>"echo 'SELECT node_id,node_name FROM node' | $SQL_DBACCESS/dbaccess
>stratacom >> $SQL_DIR/sqlresult-nodelist"
>The command above run's fine when I am logged in as a user of the machine.
>Can see a list of results read from the informix DB.
>
>When checking mailx I see a message with the following error returned from
>dbaccess/informix.
>when the cron job is runned...
>
>Your "cron" job on saturn
>/usr/users/utils/schedule/runevents
>produced the following output:
>-23101 Unable to load locale categories.
>
>What can I do to get this script-cron job to run.. All the nessacery vars
>like
>$INFORMIXDIR, $CLIEN_LOCALE, $DB_LOCALE are set in /etc/.login
>is there anything else that I missed. ??
>
>Thanks
>Neil.B
>
>my "env" variables for the sun machine are as follows
>
>HOME=/usr/users/svplus
>PATH=/sv/tools/Pure.sol/purecov-4.0.1-solaris2:/sv/tools/Xrun_sol/xrunner/bi>n:.:/usr/users/svplus:/usr/users/svplus/bin:/u
>sr/local/bin:/usr/bin:/usr/ucb:/usr/users/svplus/tools/:/usr/openwin/bin/xvi
>ew:/usr/openwin/bin:/usr/users/informix72/bin:
>/usr/users/svplus:/usr/users/svplus/bin:/opt/OV/bin:/usr/sbin:/opt/SUNWspro/
>bin:/opt/SUNWmfwm/bin:/opt/CSCOcwh/CVapp/bin:/
>opt/CSCOcv/bin:/usr/users/Wingz/bin:/usr/users/Wingz:/usr/users/svplus/tools
>/ats/bin
>LOGNAME=xvplux
>HZ=100
>TERM=vt100
>TZ=Australia/NSW
>SHELL=/bin/csh
>MAIL=/var/mail/svplus
>LC_COLLATE=en_US
>LC_CTYPE=en_US
>LC_MESSAGES=C
>LC_MONETARY=en_US
>LC_NUMERIC=en_US
>LC_TIME=en_US
>INFORMIX_DIR=/usr/users/informix72
>SVHOME=/usr/users/svplus
>PWD=/usr/users/utils/sql
>USER=svplus
>CLIENT_LOCALE=en_US
>DB_LOCALE=en_US>OS=5
>SYSTEM=SunOS
>SVPLUS_ROOT=/usr/users/svplus
>SV=/project/sv
>CVSROOT=/project/sv/master
>LM_LICENSE_FILE=/sv/tools/opt/licenses/licenses_combined
>ILVHOME=/usr/users/svplus/NWTopology/Resources
>SX11=/usr/openwin/include/X11
>MLib=/usr/openwin/lib
>MXm=/usr/openwin/include/Xm
>MX11=/usr/openwin/include/X11
>dbx=/usr/openwin/bin/xview
>INFORMIXDIR=/usr/users/informix72
>ONCONFIG=onconfig>FONT_FILE=ncd.courier
>OPENWINHOME=/usr/openwin
>XNLSPATH=/usr/users/svplus/nls
>INFORMIXSERVER=saturn>SQLEXEC=/usr/users/informix72/lib/sqlrm
>DBLANG=msg/en_us/0333
>TCL_LIBRARY=/usr/users/svplus/tools/tcl/tcl7.4/library
>ILB_NOTRACE_LMAP=
>FMHOME=/usr/users/svplus
>ILOG_LICENSE_FILE=/usr/users/svplus/config/access.ilm
>LD_LIBRARY_PATH=/usr/users/Wingz/odbc/lib:/usr/users/informix72/lib:/usr/use>rs/informix72/lib/esql:/usr/openwin/lib:/usr/lib
>WINGZSRC=/usr/users/Wingz
>WINGZ=/usr/users/Wingz
>WINGZ2=/usr/users/Wingz
>DATALINK=/usr/users/Wingz/DataLink
>DATALINKDIR=/usr/users/Wingz/DataLink
>ATS_CHECK_NO_SW_ERRORS=1
>I4LS_BIN=/opt/netls/ark/bin
>I4LS_CONF=/var/netls
>I4LS_DB=/var/netls
>NCS_BIN=/opt/ncs/install/bin
>NCS_CONF=/var/ncs
>NCS_DB=/var/ncs
>APP_DEFS=/usr/openwin/lib/app-defaults
>MERCURY_ELMHOST=bahagia
>M_ROOT=/sv/tools/Xrun_sol/xrunner
>TURBO=True
>CMAT_PROFILE=True
>
>
_________________________________________________________________
MSN 8 with e-mail virus protection service: 2 months FREE*
http://join.msn.com/?page=features/virus