Re: Informix 5 to 7 Upgrade
Posted in 1997
At 17:45 28/05/97 GMT, you wrote:
>Hello. We have just upgraded from 5 to 7, and experienceing some massive
>problems running under Solaris 2.x. We are running a 48 Gb Database which
>is constantly being accessed. The problem is, since the upgrade, Online is
>aborting about once every half hour. The ONLINE.LOG is reading:
>
>106266 Complete." "Logical Log 106266 Complete."
>12:04:19 Assert Failed: Internal Error - Segmentation Violation
>12:04:19 Who: Session(382, boris@trend, 4237, 681170648)
> Thread(332, sqlexec, 27acdef8, 5)
>12:04:19 Results: OnLine must abort
>12:04:19 Action: Reinitialize shared memory
>12:04:19 See Also: /tmp/af.14c5783
>12:04:19 rsinit.c, line 9932, thread 332, proc id 755, Segmentation
>Violation.
>12:04:19 PANIC: Attempting to bring system down>
>I am new to online, so any help would be appreciated! Thanx!
>
> -Jason
>
I had exactly the same problems last year after an upgrade from 5 to 7
on Solaris 2.5. I eventually tracked it down to something extremely silly,
and following a post to this newsgroup found out it was a known bug
(I think - memory is a bit hazy now). My application had lots of ACE
reports where the users were prompted for an integer. If a character
was entered by mistake (usually a '-' instead of '0', they are adjacent
on the keyboard!), the OnLine engine crashed with the same messages
as you are getting. Once I found this out, I repeatedly told the users what
the problem was, and they eventually started taking more care. No one
was able to tell me a better way of preventing this.
Doesn't help much, but at least you know!!
Richard.
<flamebait>
PS Changed jobs since then - working with 5.03 again - much better :-)
</flamebait>