IDS 7.3 Restore to new server
Posted in 2003
Topics: Backup & Restore, Storage & Space Management, Server Administration, Logging & Checkpoints, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
I am an
experienced DBA (not Informix) who is settng up a new system for a client.
What I need to do is backup a database on one Sun server and restore it on
another sun server. I have not been able to get this to work. The process I
have used was to copy the "ONCONFIG' file across tothe new server, update the
SQLHOSTS file and touch the files for the database chunks to create them as
empty files.
I then did a ontape (ontape -b -L0) backup to disk, copied this file across to
the new server and issued a ontape -r command. This returns the following
output
ontape -r
Please mount tape 1 on /data1/informixdata/backups/dbatest/test_backup.dmp and
press Return to continue ...
Archive Tape Information
Tape type: Archive Backup Tape
Online version: Informix Dynamic Server Version 7.31.UD4
Archive date: Tue Mar 25 16:06:36 2003
User id: informix
Terminal id: /dev/pts/4
Archive level: 0
Tape device: /data1/informixdata/backups/dbatest/test_backup.dmp
Tape blocksize (in k): 65536
Tape size (in k): 10000000
Tape number in series: 1
Spaces to restore:1 [dbatestrootdb ]
2 [dbatestlogsp ]
3 [dbatestdatasp ]
Archive Information
Informix Dynamic Server Copyright(C) 1986-1998 Informix Software, Inc.
Initialization Time 09/11/2002 15:06:01
System Page Size 2048
Version 6
Archive CheckPoint Time 03/25/2003 16:06:41
Dbspaces
number flags fchunk nchunks flags owner name
1 1 1 1 N informix dbatestrootdb
2 1 2 1 N informix dbatestlogsp
3 1 3 1 N informix dbatestdatasp
Continue restore? (y/n)y
Do you want to back up the logs? (y/n)n
Physical restore failed - could not fork server connection
Program over.
==========================================
Not knowing a lot about informix I;m not sure if this is a genuine error or is
caused by the method I am using. Any help/suggestions would be much
appreciated.
Hi Greg
When you updated the sqlhosts file, did it have an onsoctcp or onsoctli entry?
If so, then the service might not be in /etc/services on the new machine.
2) check your env variables -
INFORMIXSERVER, INFORMIXSQLHOSTS, ONCONFIG( this would be right as you see the
info u mentioned) .
Can you copy the SQLHOSTS file on mail?
Rgds
Preetinder
GREG LINTOTT wrote:
> I am an experienced DBA (not Informix) who is settng up a new system for a
client.
>
> What I need to do is backup a database on one Sun server and restore it on
another sun server. I have not been able to get this to work. The process I
have used was to copy the "ONCONFIG' file across tothe new server, update the
SQLHOSTS file and touch the files for the database chunks to create them as
empty files.
>
> I then did a ontape (ontape -b -L0) backup to disk, copied this file across
to the new server and issued a ontape -r command. This returns the following
output
>
> ontape -r>
> Please mount tape 1 on /data1/informixdata/backups/dbatest/test_backup.dmp
and press Return to continue ...
>
> Archive Tape Information
>
> Tape type: Archive Backup Tape
> Online version: Informix Dynamic Server Version 7.31.UD4
> Archive date: Tue Mar 25 16:06:36 2003
> User id: informix
> Terminal id: /dev/pts/4
> Archive level: 0
> Tape device: /data1/informixdata/backups/dbatest/test_backup.dmp
> Tape blocksize (in k): 65536
> Tape size (in k): 10000000
> Tape number in series: 1
>
> Spaces to restore:1 [dbatestrootdb ]
> 2 [dbatestlogsp ]
> 3 [dbatestdatasp ]
>
> Archive Information
>
> Informix Dynamic Server Copyright(C) 1986-1998 Informix Software, Inc.
> Initialization Time 09/11/2002 15:06:01
> System Page Size 2048
> Version 6
> Archive CheckPoint Time 03/25/2003 16:06:41
>
> Dbspaces
> number flags fchunk nchunks flags owner name
> 1 1 1 1 N informix dbatestrootdb
> 2 1 2 1 N informix dbatestlogsp
> 3 1 3 1 N informix dbatestdatasp
>
> Continue restore? (y/n)y
> Do you want to back up the logs? (y/n)n
> Physical restore failed - could not fork server connection
>
> Program over.
> ==========================================
>
> Not knowing a lot about informix I;m not sure if this is a genuine error or
is caused by the method I am using. Any help/suggestions would be much
appreciated.
----LNX_Fri_Mar_28_2003_08:51:25_V3.33-- Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Hi, = take a look at your sqlhosts-file : = Did you change the host names? Are entries in the /etc/services file on the new host for the servicename= s in sqlhosts ? Are the TCP-port(s) used by that server free on the new host ? = Regards, Andreas Kutsche ------------------------------------------------ SPAR Oesterreichische Warenhandels-AG Hauptzentrale Europastra=DFe 3 A-5015 Salzburg = Telefon : +43 662 4470 24423 E-Mail : Andreas.KUTSCHE@spar.at Internet: http://www.spar.at ------------------------------------------------ = ----LNX_Fri_Mar_28_2003_08:51:25_V3.33----
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"