Re: SQL query brings database server down
Posted in 1998
Just out of curiosity, I ran the query on our development machine (Solaris 2.5
ODS 7.12.) Sure enough it thrashed Informix, but with these entries in the log:
14:27:44 Assert Failed: Internal Error - Segmentation Violation
14:27:44 Who:Session(11425, rdouglas@hercules, 5218, 9113316)
Thread(12032, sqlexec, 891280, 1)
14:27:44 Results: OnLine must abort
14:27:44 Action: Reinitialize shared memory
14:27:44 See Also: /work/dbtemp/af.2f00c5cf, shmem.2f00c5cf.0
14:27:54 rsinit.c, line 9182, thread 12032, proc id 11401, Segmentation
Violation.
14:27:54 PANIC: Attempting to bring system down
Tue Oct 13 14:29:24 1998
> To: informix-list@iiug.org
> Subject: Re: SQL query brings database server down
> X-List-Gateway: comp.databases.informix
>
> In article <6vv7hj$b6q$1@inf6serv.rug.ac.be>, Bart Van der Cruyssen
> <Bart.VanderCruyssen@rug.ac.be> writes
> >We are working with INFORMIX Online Version 7.10.
> >Our students are using dbaccess for exercises on SQL.
> >We found out that a query like :
> >
> >SELECT first_name, last_name, address
> >FROM customers
> >WHERE "John" IN (first_name);> >
> >which is clearly syntacticly incorrect (but students try out such things),
> >does NOT result in a 'syntax error'.
> >Instead, the server goes down, reporting in "online.log" (the user name is
> >changed):
> >
> >10:20:50 Assert Failed: Internal Error - Segmentation Violation
> >10:20:50 Who: Session(20, name@server, 15722, 5)
> > Thread(44, sqlexec, a0ff514, 1)
> >10:20:50 Results: OnLine must abort
> >10:20:50 Action: Reinitialize shared memory
> >10:20:50 See Also: /tmp/af.9cba41, shmem.9cba41.0
> >10:20:51 rsdebug.c, line 3591, thread 44, proc id 23155, Segmentation
> >Violation.
> >10:20:51 PANIC: Attempting to bring system down> >
> >In my opinion, no possible input for a query (correct or incorrect) should
> >be able to bring down the database server, especially when executed from
> >within dbaccess (one of informix' own database tools).
> >
> >These are (some of) my questions:
> >- Have others experienced the same problem ?
> >- Is this a known bug ? (Note that the log file always refers to :
> >'rsdebug.c', line 3591.)
> >- Is this problem solved in later versions of the product ?
> Probably, 7.10 is an early 7.x release and there have been a lot of
> fixes done since then, move to 7.30.UC3..
>
> >- Are there any workarounds, except not trying such queries ?
> No.
>
> >- Are there other "look-like" SQL-queries known to bring down the system ?
>
>
> >
> >Thanks.
> >
> >---------------------------------------------------------------
> >Bart Van der Cruyssen Bart.VanderCruyssen@rug.ac.be
> >UNIVERSITY OF GHENT (BELGIUM) - Computer Science Laboratory
> >Sint-Pietersnieuwstraat 41, B-9000 GHENT, BELGIUM
> >tel: +32/9/264.42.23 fax: +32/9/264.42.77
> >
> >
> >
> >
>
> --
> David Williams
>
> Maintainer of the Informix FAQ
> Primary site (Beta Version) http://www.smooth1.demon.co.uk
> Official site http://www.iiug.org/techinfo/faq/faq_top.html
>
> I see you standin', Standin' on your own, It's such a lonely place for you,
For
> you to be If you need a shoulder, Or if you need a friend, I'll be here
> standing, Until the bitter end...
> So don't chastise me Or think I, I mean you harm...
> All I ever wanted Was for you To know that I care
Robert Douglas
Dairyman's Division of Land O' Lakes
robertd@dairymans.com