Re: resource permission on sysmaster (Windows)
Posted in 2009
hmmm sounds buggy...
what does a select * from sysusers say in sysmaster....
the user listed as "D" should have dba permissions... if i recall
correctly.
say that it informix is listed (it should i hope, think)
then start dbaccess choose connect
use informix and supply the passwd;
then try to create the spl....
Superboer.
On 13 apr, 05:09, "Bill Hamilton" <garage_...@hotmail.com> wrote:
> This involves IDS 11.50.TC1DE on Windows Server 2008 64 bit (win 6.0 build
> 6001 sp1).
>
> When I try to execute cdotnet.sql against sysmaster (inside dbaccess), I get
> this error on the "create procedure" statement...
>
> Error: No resource permission. (State:S1000, Native Code: FFFFFE7C)
>
> This happens if IDS is logged on as local system account OR as informix.
>
> The proc is from the informix connect folder in the /etc directory (shown
> below) .
>
> -- cdotnet.sql - creates IBM Informix .NET Provider support procedures and
> SQL objects
>
> -- DBA runs this file (against sysmaster only) to create stored procedures
>
> -- provider needs to connect to any database on the server
>
> DATABASE sysmaster;>
> CREATE PROCEDURE dotnet_isnull (x VARCHAR(32)) RETURNING INTEGER;>
> IF x IS NULL THEN
>
> RETURN 1;
>
> ELSE
>
> RETURN 0;
>
> END IF;
>
> END PROCEDURE;
>
> Informix was installed to run on the local system account, which may be the
> problem.
>
> But Informix user exists, as does the Informix-admin account.
>
> The proc will not create even if I logon as Informix and run dbaccess.
>
> It will not create even if I stop ids and change his logon to be Informix
> and restart him.
>
> Any constructive ideas would be appreciated.