Re: missing SQL exec (std engine)
Posted in 1992
In article <19921104.185537.730@almaden.ibm.com> galem@vnet.ibm.com writes: > >Upon detection of the disappeared sqlexec, we attempted closing the >database and then opening it again. This fails with an error code of >-457, WHICH IS NOT DOCUMENTED in any of our manuals. We have also been >unable to obtain any information from Informix Tech Support regarding >the meaning of this error code. Because we cannot reopen the database, >it would appear that when the original engine exited, it was not done >cleanly. But we haven't a clue about what we can look at to try and >determine what has happened. > >Any help would be very much appreciated. Thank you. > I have no idea as to why you are seeing what you are seeing. I can say that -457 means "SQL engine terminated unexpectedly". This is because the front end expects an engine to be there. The easiest way to get moving again would be to issue an sqlexit() call (this simply terminates the engine, which, though already gone, should do some additional cleanup), followed by an sqlstart(), which will start up a new engine process. You should then be able to open the database with a DATABASE statement. These two functions are, I believe, undocumented in older releases, but they should be available. Hope this is helpful. Dave -- Disclaimer: These opinions are not those of Informix Software, Inc. ************************************************************************** "I look back with some satisfaction on what an idiot I was when I was 25, but when I do that, I'm assuming I'm no longer an idiot." - Andy Rooney