Informix 7.3x Server agent extremely unreliable on NT
Posted in 1999
Topics: General Discussion
On one NT machine the "server agent" stops responding after starting. Since 7.31 it just writes 2 times "Read error occurred during connection attempt" into its log and then nothing else happens (in the log) no matter if I stop and restart the service. NT shows this service always as started. All I can do is restart the machine (up to 10 times) and hope that will work then. Sometimes it starts up again. But the problem remains the same, when the service needs to be stopped the next time. I have to do a lot of reboots until it works again. With version 7.30.TC3 and TC6 it was quite similar. There were just 3 differences: the service always wrote to its log, when it was started and stopped, wrote the "Read error ...." message very often to the log and sometimes (after a manual restart of the service) the strange message "Not owner" before it quits. Thanks Axel Weitermann
This sounds like an NT problem - ie your using it. Try a proper operating system like linux :-) On Wed, 01 Sep 1999, Axel Weitermann wrote: >On one NT machine the "server agent" stops responding after starting. Since >7.31 it just writes 2 times "Read error occurred during connection attempt" >into its log and then nothing else happens (in the log) no matter if I stop >and restart the service. NT shows this service always as started. All I can >do is restart the machine (up to 10 times) and hope that will work then. >Sometimes it starts up again. But the problem remains the same, when the >service needs to be stopped the next time. I have to do a lot of reboots >until it works again. > >With version 7.30.TC3 and TC6 it was quite similar. There were just 3 >differences: the service always wrote to its log, when it was started and >stopped, wrote the "Read error ...." message very often to the log and >sometimes (after a manual restart of the service) the strange message "Not >owner" before it quits. > > >Thanks >Axel Weitermann
It's Oracle!!! Although Oracle doesn't use the standard NT-Services file, the ports TNSListener80 is listening to, seems to be the standard TCP/IP-Ports of NT. So Oracle's TNSListener80 (which uses 1521 and 1526!!! as its ports) disturbs the IECC agent (listening at 1526) in 90% of system starts (sometimes both start up and run fine). If the IECC agent is running, you can't restart the TNSListener80 without rebooting (then the IEEC agent won't start up again in most cases) because 1526 is locked then by Informix. Solution: changing the turbo-service of Informix from 1526/tcp to any other port (because it's easier to change the Informix than the Oracle configuration) and everything works fine (Informix and Oracle). But I think that Oracle has heard that there is a DB-Manufacturer named Informix and also the other way round. So I can't understand why they are using the same port as a default value and hide it (in case of Oracle) in their own configuration file.