Re: Error restarting server
Posted in 1997
>Informix Novice Question:
Excellent question! Hard enough not to be covered in the manuals,
well enough documented to allow for a succinct answer.
>10:24:52 shmget: [EEXIST][17]: key 52574805: shared memory already exists
>10:24:52 (2) shm creation of shmem segment failed
This is the key to the answer. When the Informix oninit program goes
to allocate a segment of shared memory, it is finding that there is
already one there. Since a segment already exists where the server
is trying to put its memory, it generates that error message. This
message means one of two things: either you have another running instance
of OnLine with the same onconfig file value for SERVERNUM (which maintains
the spacing of shared memory segments in multiple residency), or you
still have a segment of shared memory left over from when you shut down
the instance the last time.
In the latter case, you must use operating system commands to remove
the segments that are no longer required. As root, run
$ipcs | grep informix
to list all informix-owned segments. In the simplest case, there is
only one. Then run $ipcrm x , where "x" is the id of the shared
memory segments.
References: INFORMIX-OnLine Dynamic Server Administrator's Guide
See index entry for Multiple Residency
Unix man pages for ipcs, ipcrm
HTH! ;)
___________________________________________________________
Clem Akins (aka clem@informix.com) <- NEW ACCOUNT!
Informix Software, Inc (Standard disclaimers apply)
International Technical Support
Last seen: 'aving Fish & Chips in Shepperton-on-Thames, UK