Replication problem or stand alone server problem
Posted in 2013
Topics: High Availability & Replication, Server Administration, Platform-Specific Issues
Hi,
We are using HDR replication for 11.50.FC9 on Aix servers. everything was working fine till last night. Due to a network glitch last night replication is not working. I tried to just bounce secondary, but the replication did not established. So I wanted to do the backup primary and restore on secondary.
The error last night in the message log says,
DR: ping time out
SMX thread is exiting because it received a CLOSE message from remote server.
The problem is I shut down the secondary and issued onmode -d standard command on the primary and nothing happens. It does not hang nor does it produces AF or nor does it crashes. I have waited up to 10 minutes and watched the message logs/and various onstats, but there is nothing I could notice. What can be the cause of this?
Regards,
Achyut
Does the onstat top line still show the primary server is in primary mode?
If the logs on the primary are secondary are still compatible you could try
putting the primary back into primary mode and run the onmode -d secondary
again on the secondary. That sometimes works when the primary and
secondary stop talking to each other.
Failing all that, open a case with IBM.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Fri, May 3, 2013 at 2:41 PM, <apgadre@gmail.com> wrote:
> Hi,
>
> We are using HDR replication for 11.50.FC9 on Aix servers. everything was
> working fine till last night. Due to a network glitch last night
> replication is not working. I tried to just bounce secondary, but the
> replication did not established. So I wanted to do the backup primary and
> restore on secondary.
>
> The error last night in the message log says,
>
> DR: ping time out
> SMX thread is exiting because it received a CLOSE message from remote
> server.
>
>
> The problem is I shut down the secondary and issued onmode -d standard
> command on the primary and nothing happens. It does not hang nor does it
> produces AF or nor does it crashes. I have waited up to 10 minutes and
> watched the message logs/and various onstats, but there is nothing I could
> notice. What can be the cause of this?
>
> Regards,
> Achyut
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>