Onbar - URGENT!!!!
Posted in 2005
Topics: Backup & Restore, Storage & Space Management
The problem is that we are trying to restore
database but we have not enough space to restore all storage spaces of the
instance, but we have enough to restore rootdbs, phyldbs, logsdbs and
docubpudbs where the entire database "bpu" is contained to recover some tables
deleted accidentally.
I performed the following:
1- copy the original oncfg_dbserver_shm.0
2- copy the original ixbar.0
3- wirte the log_number until we want to recover on the ixbar.0
4- make the links (to raw devices) only for criticals dbspaces and for
docubpudbs
5- onbar -r -p rootdbs phyldbs logsdbs docubpudbs
6- onbar -r -l
On this scenario all worked fine, but the onbar -r -l didn't stop on the log
number specified on ixbar.0 and recover the database up to now, so I couldnt
recover the tables.
As the previus didn't work, I tried the following:
1- same scenario
2- onbar -r -p rootdbs phyldbs logsdbs docubpudbs
3- onbar -r -l -n lognumber
But this opcion "n" is invalid for a not entire instance recover so this
convination didn't work
Finally I also tried:
1- make the links for the criticals dbspaces and for docubpudbs
2- make all the others links to /dev/null
3- run onbar -r -n lognumber
Thats run fine on the beggining, but when it tried to restore the first
dbspace direct to /dev/null, the onbar hunged with the following error:
"unable to start the storage specified errno=0 will not fit in the space
specified on the bar_act.log
On the online.log there are no messeges. I have to killed the onbar and the
instance.
On the other hand, I was wondering if we can do the following:
1- copy the original oncfg_dbserver_shm.0
2- copy the original ixbar.0
3- wirte the log_number until we want to recover on the ixbar.0
4- make the links (to raw devices) only for criticals dbspaces and to
docubpudbs
5- onbar -r -p rootdbs phyldbs logsdbs docubpudbs
6- onbar -r -l
7- kill the onbar when is applying the last lognumber that I want
8- If the instance don't start up nicely, anybody knows a way to clean the
inconsistances of the failed log applied?
Does anyone have any other ideas that might help?
Thanks
Viviana
Dear
Viviana
I have not tried it, but think it should work to start a restore of all
dbspaces to a point in time:
onbar -r -t <time>
or alternatively specify the correct logical log.
If the chunks for the unnecessary dbspaces do not exist , onbar should
report an error
message that it was not able to restore these dbspaces, but continue with
those it
was able to restore .
However, as I said, I haven't tested it .
Alternatively you may delete all the log files you don't want to restore in
the storage manager
(make sure you can recreate them later in case you do need them for other
purposes)
Then onbar will recognize that there a re no more logs to restore and bring
IDS into quiesscent
mode.
Best regards
Tilman
--
Tilman Model-Bosch
IBM Data Management Solutions, Informix Advanced Support
c\\\\o SAP AG
TECHDEV 05
Neurrotstr.16
69190 Walldorf
forum.subscriber@iiug.org wrote on 23.10.2005 18:00:24:
> The problem is that we are trying to restore database but we have
> not enough space to restore all storage spaces of the instance, but
> we have enough to restore rootdbs, phyldbs, logsdbs and docubpudbs
> where the entire database "bpu" is contained to recover some tables
> deleted accidentally.
>
> I performed the following:
> 1- copy the original oncfg_dbserver_shm.0
> 2- copy the original ixbar.0
> 3- wirte the log_number until we want to recover on the ixbar.0
> 4- make the links (to raw devices) only for criticals dbspaces and
> for docubpudbs
> 5- onbar -r -p rootdbs phyldbs logsdbs docubpudbs
> 6- onbar -r -l
>
> On this scenario all worked fine, but the onbar -r -l didn't stop on
> the log number specified on ixbar.0 and recover the database up to
> now, so I couldnt recover the tables.
>
> As the previus didn't work, I tried the following:
> 1- same scenario
> 2- onbar -r -p rootdbs phyldbs logsdbs docubpudbs
> 3- onbar -r -l -n lognumber
> But this opcion "n" is invalid for a not entire instance recover so
> this convination didn't work
>
> Finally I also tried:
> 1- make the links for the criticals dbspaces and for docubpudbs
> 2- make all the others links to /dev/null
> 3- run onbar -r -n lognumber
>
> Thats run fine on the beggining, but when it tried to restore the
> first dbspace direct to /dev/null, the onbar hunged with the following
error:
> "unable to start the storage specified errno=0 will not fit in the
> space specified on the bar_act.log
> On the online.log there are no messeges. I have to killed the onbar
> and the instance.
>
>
> On the other hand, I was wondering if we can do the following:
> 1- copy the original oncfg_dbserver_shm.0
> 2- copy the original ixbar.0
> 3- wirte the log_number until we want to recover on the ixbar.0
> 4- make the links (to raw devices) only for criticals dbspaces and
> to docubpudbs
> 5- onbar -r -p rootdbs phyldbs logsdbs docubpudbs
> 6- onbar -r -l
> 7- kill the onbar when is applying the last lognumber that I want
> 8- If the instance don't start up nicely, anybody knows a way to
> clean the inconsistances of the failed log applied?
>
> Does anyone have any other ideas that might help?
> Thanks
> Viviana