Re: Help Workgroup server fails to start on NT 3.51
Posted in 1997
OK, I've solved this one.
WGS needs NT 3.51 + service pack 4. So you install 3.51, then you
install the service pack to bring everything up-to-date then, because
the PC isn't networked, you install the MS loopback dummy network
device, right?
Wrong!
If you didn't install the dummy device first the service pack doesn't
update it! It appears that if you install something new you have to
re-run the service pack update afterwards.
I re-ran the service update. This allows the Server service to start
and then WGS can also start.
Intuitive, isn't it?
Ian
Ian Goddard wrote:
>
> I'm trying to get the eval distribution of Workgroup running on NT.
>
> The install wizard failed to start it.
>
> Attempting to start it via control panel/services as administrator
> produces error 1068:dependant service failed to start. The event log
> shows the error as service disabled and failed to start. Running onmode
> -m simply tells me I must be the informix administrator.
>
> Attempting to start via control panel/services also fails and the event
> log tells me that the workgroup server depends on the Server service
> which is disabled etc. Running onmode -m simply tells me that shared
> memory failed to initialise.
>
> Neither event writes to online.log.
>
> I am using the MS loopback TCP/IP device and the machine can ping itself
> with no problems.
>
> Any suggestions apart from rude comments on Windows; I can and have made
> those myself.
>
> Ian