Any ideas why ISM will not start?
Posted in 2004
Topics: General Discussion
I'm receiving the following at the cmd line when attempting to start ISM.
ISM has worked on this box in the past.
Any help would be greatly appreciated.
HPUX 11.0
Informix 9.40 FC2
Msg received at the command line:
$ ism_startupstart_ism: is starting the ISM daemons.
${0##*/}: Still waiting for ISM daemons to become available...
${0##*/}: Still waiting for ISM daemons to become available...
start_ism: ISM server not running after 2 minutes and 30 seconds.
daemon.log:
05/20/04 04:14:33 nsrd: server notice: started
05/20/04 04:14:34 nsrmmdbd: WISS error, database was not shutdown cleanly
05/20/04 04:14:34 nsrmmdbd: media db must be scavenged
05/20/04 04:14:35 nsrmmdbd: media db scavenge successful
05/20/04 04:14:35 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/20/04 04:14:35 nsrmmdbd: WISS error, an invalid slot number
05/20/04 04:14:35 nsrd: unable to start nsrmmdbd
05/20/04 04:14:35 nsrd: shutting down
05/20/04 04:14:35 nsrd: successful shutdown
05/22/04 20:13:29 nsrd: server notice: started
05/22/04 20:13:30 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/22/04 20:13:30 nsrmmdbd: WISS error, an invalid slot number
05/22/04 20:13:31 nsrd: unable to start nsrmmdbd
05/22/04 20:13:31 nsrd: shutting down
05/22/04 20:13:31 nsrd: successful shutdown
05/24/04 09:17:06 nsrd: server notice: started
05/24/04 09:17:08 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 09:17:08 nsrmmdbd: WISS error, an invalid slot number
05/24/04 09:17:08 nsrd: unable to start nsrmmdbd
05/24/04 09:17:08 nsrd: shutting down
05/24/04 09:17:08 nsrd: successful shutdown
05/24/04 10:36:14 nsrd: server notice: started
05/24/04 10:36:15 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 10:36:15 nsrmmdbd: WISS error, an invalid slot number
05/24/04 10:36:15 nsrd: unable to start nsrmmdbd
05/24/04 10:36:15 nsrd: shutting down
05/24/04 10:36:15 nsrd: successful shutdown
05/24/04 11:00:59 nsrd: server notice: started
05/24/04 11:01:00 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 11:01:00 nsrmmdbd: WISS error, an invalid slot number
05/24/04 11:01:00 nsrd: unable to start nsrmmdbd
05/24/04 11:01:00 nsrd: shutting down
05/24/04 11:01:00 nsrd: successful shutdown
This is a
multipart message in MIME format.
--=_related 00653D3485256E9E_=
Content-Type: multipart/alternative; boundary="=_alternative
00653D3485256E9E_="
--=_alternative 00653D3485256E9E_=
Content-Type: text/plain; charset="US-ASCII"
I wound up mv'ing ism, cp ISMVersion file to a new ism directory,
ism_startup -init.
Thanks to all.
Carl Williams Jr <carljr@us.ibm.com>
05/24/04 02:06 PM
To
"Darren_Jaco...." <Darren_Jacobs@carmax.com>
cc
Subject
Re: Any ideas why ISM will not start? [3012]
Hello Darren,
You can try the following sounds like you have index corruption of the
media database.
nsrck -X this will check the retention periods and expiration periods
nsrck -m this will check the media database.
If the above doesn't correct the problem then I would recommend renaming
the mm directory, and redoing the
ism_startup -init
Then ism_catalog -recreate_from device.
Hope this helps -- carl
Carl Williams Jr. - carljr@us.ibm.com
Technical Support - IBM Data Management Solutions
Tel: (800) 274-8184 Fax: (913) 599-8590 T/L 337-5260
http://www.ibm.com/software/data/informix/services
Inactive hide details for "Darren_Jaco...."
<Darren_Jacobs@carmax.com>"Darren_Jaco...." <Darren_Jacobs@carmax.com>
"Darren_Jaco...." <Darren_Jacobs@carmax.com>
Sent by: forum.subscriber@iiug.org
05/24/2004 10:14 AM
[IMAGE]
To
[IMAGE]
ids@iiug.org
[IMAGE]
cc
[IMAGE]
[IMAGE]
Subject
[IMAGE]
Any ideas why ISM will not start? [3012]
[IMAGE]
[IMAGE]
I'm receiving the following at the cmd line when attempting to start ISM.
ISM has worked on this box in the past.
Any help would be greatly appreciated.
HPUX 11.0
Informix 9.40 FC2
Msg received at the command line:
$ ism_startupstart_ism: is starting the ISM daemons.
${0##*/}: Still waiting for ISM daemons to become available...
${0##*/}: Still waiting for ISM daemons to become available...
start_ism: ISM server not running after 2 minutes and 30 seconds.
daemon.log:
05/20/04 04:14:33 nsrd: server notice: started
05/20/04 04:14:34 nsrmmdbd: WISS error, database was not shutdown cleanly
05/20/04 04:14:34 nsrmmdbd: media db must be scavenged
05/20/04 04:14:35 nsrmmdbd: media db scavenge successful
05/20/04 04:14:35 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/20/04 04:14:35 nsrmmdbd: WISS error, an invalid slot number
05/20/04 04:14:35 nsrd: unable to start nsrmmdbd
05/20/04 04:14:35 nsrd: shutting down
05/20/04 04:14:35 nsrd: successful shutdown
05/22/04 20:13:29 nsrd: server notice: started
05/22/04 20:13:30 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/22/04 20:13:30 nsrmmdbd: WISS error, an invalid slot number
05/22/04 20:13:31 nsrd: unable to start nsrmmdbd
05/22/04 20:13:31 nsrd: shutting down
05/22/04 20:13:31 nsrd: successful shutdown
05/24/04 09:17:06 nsrd: server notice: started
05/24/04 09:17:08 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 09:17:08 nsrmmdbd: WISS error, an invalid slot number
05/24/04 09:17:08 nsrd: unable to start nsrmmdbd
05/24/04 09:17:08 nsrd: shutting down
05/24/04 09:17:08 nsrd: successful shutdown
05/24/04 10:36:14 nsrd: server notice: started
05/24/04 10:36:15 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 10:36:15 nsrmmdbd: WISS error, an invalid slot number
05/24/04 10:36:15 nsrd: unable to start nsrmmdbd
05/24/04 10:36:15 nsrd: shutting down
05/24/04 10:36:15 nsrd: successful shutdown
05/24/04 11:00:59 nsrd: server notice: started
05/24/04 11:01:00 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 11:01:00 nsrmmdbd: WISS error, an invalid slot number
05/24/04 11:01:00 nsrd: unable to start nsrmmdbd
05/24/04 11:01:00 nsrd: shutting down
05/24/04 11:01:00 nsrd: successful shutdown
--=_alternative 00653D3485256E9E_=
Content-Type: text/html; charset="US-ASCII"
<br><font size=2 face="sans-serif">I wound up mv'ing ism, cp ISMVersion
file to a new ism directory, ism_startup -init. </font>
<br>
<br><font size=2 face="sans-serif">Thanks to all. </font>
<br>
<br>
<br>
<br>
<table width=100%>
<tr valign=top>
<td width=40%><font size=1 face="sans-serif"><b>Carl Williams Jr
<carljr@us.ibm.com></b>
</font>
<p><font size=1 face="sans-serif">05/24/04 02:06 PM</font>
<td width=59%>
<table width=100%>
<tr>
<td>
<div align=right><font size=1 face="sans-serif">To</font></div>
<td valign=top><font size=1 face="sans-serif">"Darren_Jaco...."
<Darren_Jacobs@carmax.com></font>
<tr>
<td>
<div align=right><font size=1 face="sans-serif">cc</font></div>
<td valign=top>
<tr>
<td>
<div align=right><font size=1 face="sans-serif">Subject</font></div>
<td valign=top><font size=1 face="sans-serif">Re: Any ideas why ISM will
not start? [3012]</font></table>
<br>
<table>
<tr valign=top>
<td>
<td></table>
<br></table>
<br>
<br>
<br>
<br>
<br><font size=3>Hello Darren,</font>
<br>
<br><font size=3>You can try the following sounds like you have index
corruption
of the media database.</font>
<br>
<br><font size=3>nsrck -X this will check the retention periods and
expiration periods</font>
<br>
<br><font size=3>nsrck -m this will check the media database.</font>
<br>
<br><font size=3>If the above doesn't correct the problem then I would
recommend renaming the mm directory, and redoing the </font>
<br><font size=3>ism_startup -init</font>
<br>
<br><font size=3>Then ism_catalog -recreate_from device.</font>
<br>
<br><font size=3>Hope this helps -- carl</font>
<br>
<br><font size=3>Carl Williams Jr. - carljr@us.ibm.com</font>
<br><font size=3>Technical Support - IBM Data Management Solutions</font>
<br><font size=3>Tel: (800) 274-8184 Fax: (913) 599-8590
T/L 337-5260</font>
<br><a href=http://www.ibm.com/software/data/informix/services><font size=3
color=blue><u>http://www.ibm.com/software/data/informix/services</u></font></a>
<br>
<br><font size=3>Inactive hide details for "Darren_Jaco...."
<Darren_Jacobs@carmax.com>"Darren_Jaco...."
<Darren_Jacobs@carmax.com></font>
<br>
<br>
<br>
<table width=100%>
<tr valign=top>
<td width=40%>
<br><font size=2><b>"Darren_Jaco...."
<Darren_Jacobs@carmax.com></b>
</font>
<br><font size=2>Sent by: forum.subscriber@iiug.org</font><font size=3>
</font>
<br>
<br><font size=2>05/24/2004 10:14 AM</font>
<br>
<br>
<td width=59%>
<table width=100%>
<tr valign=top>
<td width=11%><font size=1 color=red face="sans-serif">[IMAGE]</font>
<div align=right>
<br><font size=2>To</font></div>
<td width=88%><font size=1 color=red face="sans-serif">[IMAGE]</font>
<br><font size=2>ids@iiug.org</font>
<tr valign=top>@
We had this error before, it happened at times when we performed a restore of
/informix/<SID>/ism directory.
Realised that to avoid this problem, the ism engine should be shutdown before a
backup of /informix/<SID>/ism directory.
An OSS note was subsequently edited to include this as a caution to users who
may be do a backup and restore of this sort.
Regards
Dominic
"Darren_Jaco...." <Darren_Jacobs@carmax.com> on 05/24/2004 11:14:51 PM
To: ids@iiug.org
cc: (bcc: Dominic Seah Chin Teck/MEH/SG/Parkway)
Subject: Any ideas why ISM will not start? [3012]
I'm receiving the following at the cmd line when attempting to start ISM.
ISM has worked on this box in the past.
Any help would be greatly appreciated.
HPUX 11.0
Informix 9.40 FC2
Msg received at the command line:
$ ism_startupstart_ism: is starting the ISM daemons.
${0##*/}: Still waiting for ISM daemons to become available...
${0##*/}: Still waiting for ISM daemons to become available...
start_ism: ISM server not running after 2 minutes and 30 seconds.
daemon.log:
05/20/04 04:14:33 nsrd: server notice: started
05/20/04 04:14:34 nsrmmdbd: WISS error, database was not shutdown cleanly
05/20/04 04:14:34 nsrmmdbd: media db must be scavenged
05/20/04 04:14:35 nsrmmdbd: media db scavenge successful
05/20/04 04:14:35 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/20/04 04:14:35 nsrmmdbd: WISS error, an invalid slot number
05/20/04 04:14:35 nsrd: unable to start nsrmmdbd
05/20/04 04:14:35 nsrd: shutting down
05/20/04 04:14:35 nsrd: successful shutdown
05/22/04 20:13:29 nsrd: server notice: started
05/22/04 20:13:30 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/22/04 20:13:30 nsrmmdbd: WISS error, an invalid slot number
05/22/04 20:13:31 nsrd: unable to start nsrmmdbd
05/22/04 20:13:31 nsrd: shutting down
05/22/04 20:13:31 nsrd: successful shutdown
05/24/04 09:17:06 nsrd: server notice: started
05/24/04 09:17:08 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 09:17:08 nsrmmdbd: WISS error, an invalid slot number
05/24/04 09:17:08 nsrd: unable to start nsrmmdbd
05/24/04 09:17:08 nsrd: shutting down
05/24/04 09:17:08 nsrd: successful shutdown
05/24/04 10:36:14 nsrd: server notice: started
05/24/04 10:36:15 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 10:36:15 nsrmmdbd: WISS error, an invalid slot number
05/24/04 10:36:15 nsrd: unable to start nsrmmdbd
05/24/04 10:36:15 nsrd: shutting down
05/24/04 10:36:15 nsrd: successful shutdown
05/24/04 11:00:59 nsrd: server notice: started
05/24/04 11:01:00 nsrmmdbd: error adding btrees to ss (an invalid slot
number)
05/24/04 11:01:00 nsrmmdbd: WISS error, an invalid slot number
05/24/04 11:01:00 nsrd: unable to start nsrmmdbd
05/24/04 11:01:00 nsrd: shutting down
05/24/04 11:01:00 nsrd: successful shutdown