Hi,
While starting up informix in multi user mode , we wait for the
database to come up by checking the onstat - o/p . But if the system
is loaded, even after onstat shows status as online , the connection
is rejected by the database .
The wait loop that we do is as follows
--------------------------------------------------------
onmode -m
#
# The creation returns pretty quickly, but the server stays in
# single-user mode until initialization is complete. Wait for the
# server to leave single-user mode.
#
while true; do
progress
dbstatus=`onstat -k`
echo $dbstatus | grep 'On-Line' > ${debug_device:-/dev/null} 2>&1
if [ $? -eq 0 ] ; then
break # done initializing
fi
sleep 5
done
#start db access
---------------------
The db access fails to connect in some cases when system is heavily
loaded
Am i doing something wrong here ? Is this a bug ? Is there a
workaround
I am using Informix 9.21 UC 1
Thanks ,
upendra